summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-03-07 14:21:38 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-03-07 14:29:41 +0100
commit3d06c8336732004eb0c2c41cc7de64b04e0fca96 (patch)
treee0d2c985acac411e650cb840389e506ae35e5e9c /dev-ml/tyxml/tyxml-4.1.0.ebuild
parentmedia-radio/unixcw: Version bump. Fix tinfo problem. (diff)
downloadgentoo-3d06c8336732004eb0c2c41cc7de64b04e0fca96.tar.gz
gentoo-3d06c8336732004eb0c2c41cc7de64b04e0fca96.tar.bz2
gentoo-3d06c8336732004eb0c2c41cc7de64b04e0fca96.zip
dev-ml/tyxml: Bump to 4.1.0
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-ml/tyxml/tyxml-4.1.0.ebuild')
-rw-r--r--dev-ml/tyxml/tyxml-4.1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ml/tyxml/tyxml-4.1.0.ebuild b/dev-ml/tyxml/tyxml-4.1.0.ebuild
new file mode 100644
index 000000000000..4ddf289c7b6e
--- /dev/null
+++ b/dev-ml/tyxml/tyxml-4.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+# Cannot find findlib package alcotest
+# OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="A libary to build xml trees typechecked by OCaml"
+HOMEPAGE="http://ocsigen.org/tyxml/"
+SRC_URI="https://github.com/ocsigen/tyxml/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ppx +camlp4"
+
+DEPEND="
+ >=dev-ml/uutf-1.0:=
+ dev-ml/uchar:=
+ dev-ml/ocaml-re:=
+ ppx? ( >=dev-ml/ppx_tools-5:= dev-ml/markup:= )
+ camlp4? ( dev-ml/camlp4:= )"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGES README.md )
+
+src_configure() {
+ oasis_configure_opts="
+ $(use_enable camlp4 syntax)
+ $(use_enable ppx)
+ " oasis_src_configure
+}