summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-07 12:12:12 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-07 12:23:10 +0200
commit64cfc999ca04867aa77a84b4696084f504a498f2 (patch)
treeb4c0be349bf30acbcb62af6653df9bf41a72a023 /dev-ml/uchar/uchar-0.0.1.ebuild
parentwww-client/chromium: dev channel bump (54.0.2840.14) (diff)
downloadgentoo-64cfc999ca04867aa77a84b4696084f504a498f2.tar.gz
gentoo-64cfc999ca04867aa77a84b4696084f504a498f2.tar.bz2
gentoo-64cfc999ca04867aa77a84b4696084f504a498f2.zip
dev-ml/uchar: initial import; ebuild by me
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ml/uchar/uchar-0.0.1.ebuild')
-rw-r--r--dev-ml/uchar/uchar-0.0.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/uchar/uchar-0.0.1.ebuild b/dev-ml/uchar/uchar-0.0.1.ebuild
new file mode 100644
index 000000000000..2cf183d878ed
--- /dev/null
+++ b/dev-ml/uchar/uchar-0.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Uchar compatibility library"
+HOMEPAGE="https://github.com/ocaml/uchar"
+SRC_URI="https://github.com/ocaml/uchar/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND="dev-lang/ocaml:="
+DEPEND="${RDEPEND}
+ dev-ml/opam"
+
+src_compile() {
+ ocaml pkg/build.ml \
+ "native=$(usex ocamlopt true false)" \
+ "native-dynlink=$(usex ocamlopt true false)" || die
+}
+
+src_test() {
+ ocamlbuild -X src -use-ocamlfind -pkg uchar test/testpkg.native || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc README.md CHANGES.md
+}