summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-07-04 17:11:48 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-07-04 17:11:48 +0200
commitc6f38e0711159034a5e89ae1c9cf2b5ee552b73e (patch)
tree5cf8cc7ad3c90532a5c259e92c91c6609875aecb /dev-ml/utop
parentdev-ml/utop: enable Emacs support (diff)
downloadgentoo-c6f38e0711159034a5e89ae1c9cf2b5ee552b73e.tar.gz
gentoo-c6f38e0711159034a5e89ae1c9cf2b5ee552b73e.tar.bz2
gentoo-c6f38e0711159034a5e89ae1c9cf2b5ee552b73e.zip
dev-ml/utop: bump to 2.9.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml/utop')
-rw-r--r--dev-ml/utop/Manifest1
-rw-r--r--dev-ml/utop/utop-2.9.2.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-ml/utop/Manifest b/dev-ml/utop/Manifest
index d37e92506871..a5a7cf9c9f12 100644
--- a/dev-ml/utop/Manifest
+++ b/dev-ml/utop/Manifest
@@ -1,3 +1,4 @@
DIST utop-2.8.0.tar.gz 414059 BLAKE2B f94cc9a2e87d5341b1d7231574b1e0d8b179e600640281529ecfd2ce8827b9145d73030ea1ec59b20430d34155087f6d910c698c75d7566145c9db3a3ecbf872 SHA512 cf323249aa9a747081b3e39e8e8b99b69557082beb244dd0a28d64c6d11e3c03427c22da4fd364e9ae7f5d83d12ca3d2d48b9f4b6697ec704d486f3c23163dba
DIST utop-2.9.0.tar.gz 414953 BLAKE2B 96fbf38d4a638137b73264bc523b8a81e47ddd609a7987073313f4b1d628e4e84c31f98195105911dd0930b8d27007cf5cc1633771bc6d2e975bd169e1e3ba9c SHA512 dd3f52fb915493cb32b5ee722361e884a481d04ef175d5bdf58f4032b70826c38b2f5279b7c64b78961170a86bc80fbd59f03026fac99bb5da2b46a8f341aa45
DIST utop-2.9.1.tar.gz 421430 BLAKE2B c90a7fe54c5fbf15ce209e9bf850031e0368104c1f8f61a2d982b2b43d87b4bb95c91e3af6da16ae27ebfab71f2b9907e7dec68d34f619597fe8db45ff363bf4 SHA512 10942a4c7d2e13081f2e02c29b767863176fe90ca5baf48d3be47bb0871a12840d873e5d3eb7d7dd9b0362e849f70afb913ff50c07e66c6b7f221c8bb98fa469
+DIST utop-2.9.2.tar.gz 421512 BLAKE2B 235b4739e644877e4b9eef432a00ba053f42f2b4d4fdd9b0bd925af736d9a351c8f9373031bc4fc23835872034d48a27b8eac99d286f57cb975d2b1368f420c8 SHA512 14dd690b459cfea90c565b397b5d914add7e92b152b476ab58576dc827fa204b3d721955bfc3508bcb953778a8d6fb3b299b0293f8ddf64b3f0155fc9a0e7fda
diff --git a/dev-ml/utop/utop-2.9.2.ebuild b/dev-ml/utop/utop-2.9.2.ebuild
new file mode 100644
index 000000000000..cd05e5fc7a0c
--- /dev/null
+++ b/dev-ml/utop/utop-2.9.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune elisp-common
+
+DESCRIPTION="Universal toplevel for OCaml"
+HOMEPAGE="https://github.com/ocaml-community/utop"
+SRC_URI="https://github.com/ocaml-community/utop/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs +ocamlopt"
+
+ELISP_DEPEND="
+ emacs? (
+ >=app-editors/emacs-24:*
+ >=app-emacs/tuareg-mode-2.2.0
+ )
+"
+DEPEND="
+ dev-ml/camomile:=
+ dev-ml/lambda-term:=
+ dev-ml/lwt:=
+ dev-ml/react:=
+"
+RDEPEND="
+ ${DEPEND}
+ ${ELISP_DEPEND}
+"
+BDEPEND="
+ dev-ml/cppo
+ dev-ml/findlib
+ ${ELISP_DEPEND}
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ dune_src_compile
+
+ use emacs &&
+ BYTECOMPFLAGS="-L src/top" elisp-compile src/top/*.el
+}
+
+src_install() {
+ dune_src_install
+
+ if use emacs ; then
+ elisp-install ${PN} src/top/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}