summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-21 00:29:30 +0000
committerSam James <sam@gentoo.org>2021-04-21 02:09:40 +0000
commit615af28d42ca199cbd60833ed6544d654ec4ad59 (patch)
treedc6c2d3680a7655fc3c6a394ed8630b9acc1d1a7 /dev-ml/uutf/uutf-1.0.1.ebuild
parentdev-ml/reactiveData: drop 9999 (diff)
downloadgentoo-615af28d42ca199cbd60833ed6544d654ec4ad59.tar.gz
gentoo-615af28d42ca199cbd60833ed6544d654ec4ad59.tar.bz2
gentoo-615af28d42ca199cbd60833ed6544d654ec4ad59.zip
dev-ml/uutf: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/uutf/uutf-1.0.1.ebuild')
-rw-r--r--dev-ml/uutf/uutf-1.0.1.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/dev-ml/uutf/uutf-1.0.1.ebuild b/dev-ml/uutf/uutf-1.0.1.ebuild
index 47b4c9ac86d5..ca6cd4708b6e 100644
--- a/dev-ml/uutf/uutf-1.0.1.ebuild
+++ b/dev-ml/uutf/uutf-1.0.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
inherit findlib
@@ -35,7 +35,7 @@ src_test() {
ocamlbuild -use-ocamlfind tests.otarget || die
pushd _build/test || die
./test.native || die
- #Rebuild to avoid mismatches between installed files, bug #604674
+ # Rebuild to avoid mismatches between installed files, bug #604674
popd || die
ocaml pkg/pkg.ml build \
--with-cmdliner "$(usex utftrip true false)" \
@@ -49,9 +49,15 @@ src_install() {
# Can't use opam-installer here as it is an opam dep...
findlib_src_preinst
local nativelibs=""
+
use ocamlopt && nativelibs="$(echo _build/src/uutf.cm{x,xa,xs} _build/src/uutf.a)"
ocamlfind install uutf _build/pkg/META _build/src/uutf.mli _build/src/uutf.cm{a,i} ${nativelibs} || die
+
use utftrip && newbin utftrip.$(usex ocamlopt native byte) utftrip
dodoc CHANGES.md README.md
- use doc && dohtml -r doc/*
+
+ if use doc ; then
+ docinto html
+ dodoc -r doc/*
+ fi
}