summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 18:02:21 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-02 10:37:47 +0200
commit998eeb7c82563f83d1cd211caa522d310261e6b7 (patch)
treecf009de9f11cd3bb5a4a738b0c046c79742a25c6 /dev-ml/variantslib/variantslib-0.9.0.ebuild
parentdev-ml/core_kernel: Bump to 0.9.0 (diff)
downloadgentoo-998eeb7c82563f83d1cd211caa522d310261e6b7.tar.gz
gentoo-998eeb7c82563f83d1cd211caa522d310261e6b7.tar.bz2
gentoo-998eeb7c82563f83d1cd211caa522d310261e6b7.zip
dev-ml/variantslib: Bump to 0.9.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/variantslib/variantslib-0.9.0.ebuild')
-rw-r--r--dev-ml/variantslib/variantslib-0.9.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/variantslib/variantslib-0.9.0.ebuild b/dev-ml/variantslib/variantslib-0.9.0.ebuild
new file mode 100644
index 000000000000..7bb8fed42f09
--- /dev/null
+++ b/dev-ml/variantslib/variantslib-0.9.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="OCaml variants as first class values"
+HOMEPAGE="https://github.com/janestreet/variantslib"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-lang/ocaml:=
+ dev-ml/base:=
+ dev-ml/ppx_driver:=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+DEPEND="${RDEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}