summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-10-23 10:26:16 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-10-23 11:27:19 +0200
commit57238c8420914cbaaa599f23ae866b9615c5032c (patch)
tree2d7a736510d9a90d13eb6981d47147047aa81bc7 /dev-ml/yojson/yojson-2.0.2-r2.ebuild
parentdev-ruby/rspec-memory: update SRC_URI (diff)
downloadgentoo-57238c8420914cbaaa599f23ae866b9615c5032c.tar.gz
gentoo-57238c8420914cbaaa599f23ae866b9615c5032c.tar.bz2
gentoo-57238c8420914cbaaa599f23ae866b9615c5032c.zip
dev-ml/yojson: hard block seq lower than 0.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml/yojson/yojson-2.0.2-r2.ebuild')
-rw-r--r--dev-ml/yojson/yojson-2.0.2-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ml/yojson/yojson-2.0.2-r2.ebuild b/dev-ml/yojson/yojson-2.0.2-r2.ebuild
new file mode 100644
index 000000000000..b2c26c811dab
--- /dev/null
+++ b/dev-ml/yojson/yojson-2.0.2-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="JSON parsing and pretty-printing library for OCaml"
+HOMEPAGE="https://github.com/ocaml-community/yojson"
+SRC_URI="https://github.com/ocaml-community/yojson/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="examples +ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.07:=[ocamlopt?]
+ !!<dev-ml/seq-0.3
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-ml/cppo-1.6.1
+ test? ( dev-ml/alcotest )
+"
+
+src_prepare() {
+ default
+ # let's not build this
+ rm bench/dune yojson-bench.opam || die
+}
+
+src_install() {
+ dune_src_install
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}