summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-30 16:37:45 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-30 20:08:29 +0200
commit110cc72b82a2706237d5d9ae5ea6e3fc50c75fcd (patch)
tree3849bda5666abda62a82e42b7e2587fc64872e09 /dev-ml
parentdev-ml/qcheck: bump to 0.6 (diff)
downloadgentoo-110cc72b82a2706237d5d9ae5ea6e3fc50c75fcd.tar.gz
gentoo-110cc72b82a2706237d5d9ae5ea6e3fc50c75fcd.tar.bz2
gentoo-110cc72b82a2706237d5d9ae5ea6e3fc50c75fcd.zip
dev-ml/utop: bump to 2.0.1
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/utop/Manifest1
-rw-r--r--dev-ml/utop/utop-2.0.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-ml/utop/Manifest b/dev-ml/utop/Manifest
index cbde3cb1891a..5810adf7392d 100644
--- a/dev-ml/utop/Manifest
+++ b/dev-ml/utop/Manifest
@@ -1,2 +1,3 @@
DIST utop-1.19.3.tar.gz 105213 SHA256 9dbca07b8c55700473cca1d9dd975abb9c6cd03e715dec4857f1249bee16e09b SHA512 97b3fec8b6f930efa742230058eba6fb846900d71e5758903dcefe03fa08e93b54e32642a5b8b6ad02aed7e81ccd6146e87a92805eb74aa4fae275a1188818cd WHIRLPOOL 470e5739639440b11905fbd4f755643aa3117f9fe76690723df7e2fba07e1bdcfcb7ad796a9dc2d00b3be3a6f0eba1afa335ce826a8c715ac40681ad38165599
DIST utop-2.0.0.tar.gz 57421 SHA256 0a69e5ec055db223cf878d7fdda3b389dc5d42649cc99b5877db507767ce52b6 SHA512 12def269f18be292645d6339f80ffe85823d8095940acb57a03f99ea3f2fe2559662921e3a38d6381ec7246245164b5e2c6b5fc843bdb4fd07ad2377c73da207 WHIRLPOOL 8baf739295132c785d55001bba2aabe24e0f4b3e78214be3a3ac19ffa8baa80ab513d31225500f2dc18018284267be6a235d012f32d7e6c68c829e98358f1410
+DIST utop-2.0.1.tar.gz 57523 SHA256 5a93793a3a33724716bdb8e6829eaa85a792c5f5939eb86f5d8bbf1df85f42ec SHA512 66e7858a44ddd038f08073f9530c790f3ad44134899793c9f5e689d0e1786d2e2751bf38c6be33979292942b00dd6ff2db421025e12f49e05c4a694df36d23e3 WHIRLPOOL bfb06654e52f124739eeeb1568157d6377f8749eddaaf5c0761056da5754a486f9db0f89a21d60c1030be88400bd1cf5782c58337421c56412ea8b5b7631ed9f
diff --git a/dev-ml/utop/utop-2.0.1.ebuild b/dev-ml/utop/utop-2.0.1.ebuild
new file mode 100644
index 000000000000..3bfacb103f46
--- /dev/null
+++ b/dev-ml/utop/utop-2.0.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="A new toplevel for OCaml with completion and colorization"
+HOMEPAGE="https://github.com/diml/utop"
+SRC_URI="https://github.com/diml/utop/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ >=dev-ml/lwt-2.4.0:=
+ dev-ml/lwt_react:=
+ >=dev-ml/lambda-term-1.2:=
+ >=dev-ml/zed-1.2:=
+ >=dev-ml/cppo-1.0.1:=
+ dev-ml/findlib:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/opam
+ dev-ml/jbuilder"
+
+DOCS=( "CHANGES.md" "README.md" )
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ --mandir="${ED}/usr/share/man" \
+ ${PN}.install || die
+}