summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorHank Leininger <hlein@korelogic.com>2021-05-04 16:48:16 -0600
committerSam James <sam@gentoo.org>2021-06-06 23:55:13 +0000
commit121f73a4e94454e2fc6fe3b200f9b40eaf2464c4 (patch)
tree576cd629c598ef0266e8b2f4cee1ec067d4e8fd3 /dev-ml
parentdev-python/lazr-config: add 2.2.3 (diff)
downloadgentoo-121f73a4e94454e2fc6fe3b200f9b40eaf2464c4.tar.gz
gentoo-121f73a4e94454e2fc6fe3b200f9b40eaf2464c4.tar.bz2
gentoo-121f73a4e94454e2fc6fe3b200f9b40eaf2464c4.zip
dev-ml/dose3: version bump for newer ocaml compat.
Switched to the Dune build system by copy-paste from other ebuilds. Caveats: I don't know the right way to make some components optional with Dune build systems; therefore, everything that used to be conditional on USE is now mandatory. Also, ocaml-base64 is only KEYWORDS=~amd64, so as a result that is the only arch I could keep for dose3-6 atm without repoman having a fit. Signed-off-by: Hank Leininger <hlein@korelogic.com> Closes: https://bugs.gentoo.org/769821 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/dose3/Manifest2
-rw-r--r--dev-ml/dose3/dose3-6.0.1_p2.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-ml/dose3/Manifest b/dev-ml/dose3/Manifest
index aaee3c2d0d8a..13da65b08766 100644
--- a/dev-ml/dose3/Manifest
+++ b/dev-ml/dose3/Manifest
@@ -1,2 +1,4 @@
DIST dose3_5.0.1-16.debian.tar.xz 39448 BLAKE2B a5ae8c74ee1a5a89bf3594cbaf0b37703fcf03a03e336c6b91626fcb6767518c517bf28ec4a24f6cbeb40e1544b34e95855507f39aacca110e8daa6e6e5d3994 SHA512 52d14a45bc0b0a66c4cf3acc05b479b1456c78fa8cb0e453a01dd2f0d849dfcf959bd9e8ff8d505272ad7ad542ff402013746816ead3ccd2dbd0bed572ee2930
DIST dose3_5.0.1.orig.tar.gz 297433 BLAKE2B 74ae954604f26398f091b4f14d2a633132ae62102f52af13284af27e41cd7c47afb1b533b0821a8921ba33fa6658e94b3bb6bf5f104f48881a50e14517cd65e2 SHA512 e66526319446054041f138ee2633043d0832089f6a554cf566a28de899d10383acfb1aa6bf1a368811602939676510933a7d2404fd34dbeba15045b458f5af84
+DIST dose3_6.0.1-2.debian.tar.xz 23320 BLAKE2B 0351a715756b76c1f81fdf5599d10373ce85554f1d63b4dcbaa647dcf81b099e59c68f93413ca391bdf17b52831b085a7d2b86bc64d86676763bbabd7804a6a4 SHA512 219bb7614d1200adb5d22032cb3d7442c16cdce785088f58b3fcc188856b93817f0157ea6ed1bd72e1f565b9a98df145c188e0fa5d7f538d616b7eccc20ab706
+DIST dose3_6.0.1.orig.tar.gz 1417354 BLAKE2B c5fb08c853d2d3589416237addf767912fffab5ef74b7f3332799ae350a371307bd06a24abe6565d2d00aedc01f58d0a2583db6d2d76fc2ebee634b05405ab86 SHA512 cb9dad4ae296b85317f60133bb9dcc63dad8560486e2bd83139205810643e701de5e9834d8d2de34d8237d0abfd394970088c73eeab08956fc9c4178411303ea
diff --git a/dev-ml/dose3/dose3-6.0.1_p2.ebuild b/dev-ml/dose3/dose3-6.0.1_p2.ebuild
new file mode 100644
index 000000000000..ca51186d7fa3
--- /dev/null
+++ b/dev-ml/dose3/dose3-6.0.1_p2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Library to perform analysis on package repositories"
+HOMEPAGE="http://www.mancoosi.org/software/ https://gforge.inria.fr/projects/dose"
+SRC_URI="http://deb.debian.org/debian/pool/main/d/dose3/${PN}_$(ver_cut 1-3).orig.tar.gz"
+SRC_URI+=" http://deb.debian.org/debian/pool/main/d/dose3/${PN}_${PV/_p/-}.debian.tar.xz"
+S="${WORKDIR}/${PN}-$(ver_cut 1-3)"
+
+LICENSE="LGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt test"
+
+BDEPEND="
+ dev-ml/findlib
+ dev-ml/ocamlbuild
+"
+RDEPEND="
+ >=dev-lang/ocaml-4.03:=[ocamlopt=]
+ dev-ml/ocaml-base64:=[ocamlopt=]
+ >=dev-ml/cudf-0.7:=[ocamlopt=]
+ >=dev-ml/extlib-1.7.8:=[ocamlopt=]
+ >=dev-ml/ocamlgraph-2.0.0:=[ocamlopt=]
+ >=dev-ml/re-1.2.2:=[ocamlopt=]
+ dev-ml/parmap:=[ocamlopt=]
+ >=dev-ml/camlzip-1.08:=[ocamlopt=]
+ >=dev-ml/camlbz2-0.7.0:=
+ dev-ml/ocaml-expat:=[ocamlopt=]
+ dev-ml/xml-light:=[ocamlopt=]
+ app-arch/rpm
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pyyaml[libyaml] )
+"
+
+# missing test data
+RESTRICT="test"
+
+QA_FLAGS_IGNORED='.*'
+
+src_prepare() {
+ default
+
+ elog "Applying Debian patchset..."
+ for file in "${WORKDIR}"/debian/patches/*.patch ; do
+ eapply "${file}"
+ done
+}