summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-11-28 13:12:26 -0500
committerAaron Bauman <bman@gentoo.org>2020-11-28 13:37:16 -0500
commit2b5d982e0f5fe005153f563f59ac89c0752842fc (patch)
treef142955a45daea8581cf046323a3d4a9ed98f8cf /dev-ml
parentdev-ml/cudf: drop old (diff)
downloadgentoo-2b5d982e0f5fe005153f563f59ac89c0752842fc.tar.gz
gentoo-2b5d982e0f5fe005153f563f59ac89c0752842fc.tar.bz2
gentoo-2b5d982e0f5fe005153f563f59ac89c0752842fc.zip
dev-ml/dose3: drop old
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/dose3/dose3-5.0.1.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/dev-ml/dose3/dose3-5.0.1.ebuild b/dev-ml/dose3/dose3-5.0.1.ebuild
deleted file mode 100644
index 161fafebbd3f..000000000000
--- a/dev-ml/dose3/dose3-5.0.1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils
-
-MY_P="${P/_beta/-beta}"
-DESCRIPTION="Library to perform analysis on package repositories"
-HOMEPAGE="http://www.mancoosi.org/software/ https://gforge.inria.fr/projects/dose"
-SRC_URI="https://gforge.inria.fr/frs/download.php/file/36063/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
-IUSE="+ocamlopt parmap zip bzip2 xml curl rpm4 test"
-
-RDEPEND="
- >=dev-lang/ocaml-3.12:=[ocamlopt?]
- dev-ml/cudf:=
- >=dev-ml/extlib-1.7.0:=
- dev-ml/ocaml-re:=
- dev-ml/cppo:=
- parmap? ( dev-ml/parmap:= )
- zip? ( dev-ml/camlzip:= )
- bzip2? ( dev-ml/camlbz2:= )
- >=dev-ml/ocamlgraph-1.8.6:=
- xml? ( dev-ml/ocaml-expat:= dev-ml/xml-light:= )
- curl? ( dev-ml/ocurl:= )
- rpm4? ( app-arch/rpm )
-"
-DEPEND="${RDEPEND}
- dev-ml/findlib
- dev-ml/ocamlbuild
- test? ( dev-python/pyyaml[libyaml] )
-"
-# missing test data
-RESTRICT="test"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- sed -e 's/INSTALLOPTS=-s/INSTALLOPTS=/' -i Makefile.config.in || die
-}
-
-src_configure() {
- econf \
- $(use ocamlopt || echo "--with-bytecodeonly") \
- $(use parmap && echo "--with-parmap") \
- $(use zip && echo "--with-zip") \
- $(use bzip2 && echo "--with-bz2") \
- $(use xml && echo "--with-xml") \
- $(use curl && echo "--with-curl") \
- $(use rpm4 && echo "--with-rpm4")
-}
-
-src_compile() {
- emake -j1
-}
-
-src_install() {
- emake DESTDIR="${D}" BINDIR="${ED}/usr/bin" install
- dodoc CHANGES CREDITS README.architecture TODO
-}