summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 13:38:20 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-01 14:24:44 +0200
commit2b926560846c14843a96f1d8aa1c5be27828ede4 (patch)
tree355fa6dfcdbf89182639992502292ae60d240ae5 /dev-ml
parentdev-ml/easy-format: Bump to 1.2.0 (diff)
downloadgentoo-2b926560846c14843a96f1d8aa1c5be27828ede4.tar.gz
gentoo-2b926560846c14843a96f1d8aa1c5be27828ede4.tar.bz2
gentoo-2b926560846c14843a96f1d8aa1c5be27828ede4.zip
dev-ml/atd: Initial import. Ebuild by me.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/atd/Manifest1
-rw-r--r--dev-ml/atd/atd-1.2.0.ebuild32
-rw-r--r--dev-ml/atd/metadata.xml8
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-ml/atd/Manifest b/dev-ml/atd/Manifest
new file mode 100644
index 000000000000..ff0f798a76d5
--- /dev/null
+++ b/dev-ml/atd/Manifest
@@ -0,0 +1 @@
+DIST atd-1.2.0.tar.gz 41300 SHA256 488e06e406824efab12f53845b648c1a592c2c8349d4ac1e12b94ce61e7453e9 SHA512 a52824c9784ac0f4d6f314972fa1d92be14730de3c6bde04032004579ac27408385bd4fa7d926f9d564657eb62050fd732a032f364bada62a1dc7a8acfacb727 WHIRLPOOL b0fe31df2282e5533c6c5bc769a9dfedfc60b5457ccf5e0b7fed82d1da287b72cee3bf1133891e2abe674afb70df781a94200e17bdb0011a45af3f492ae38b1e
diff --git a/dev-ml/atd/atd-1.2.0.ebuild b/dev-ml/atd/atd-1.2.0.ebuild
new file mode 100644
index 000000000000..fa19f7ffc258
--- /dev/null
+++ b/dev-ml/atd/atd-1.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="Syntax for cross-language type definitions"
+HOMEPAGE="https://github.com/mjambon/atd"
+SRC_URI="https://github.com/mjambon/atd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-lang/ocaml:=[ocamlopt?]
+ dev-ml/easy-format:=[ocamlopt?]
+"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake -j1 all
+ use ocamlopt && emake opt
+}
+
+src_install() {
+ dodir /usr/bin
+ PREFIX="${ED}/usr" findlib_src_install
+ dodoc README.md
+}
diff --git a/dev-ml/atd/metadata.xml b/dev-ml/atd/metadata.xml
new file mode 100644
index 000000000000..ffac4d7ebc01
--- /dev/null
+++ b/dev-ml/atd/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>