summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-28 03:21:05 +0100
committerSam James <sam@gentoo.org>2021-07-28 03:21:05 +0100
commit2ca90f4a11fe6fb3a7d7ad8d012ee3c4fbd8cbba (patch)
treeb381f5592543c62c72deaddaf63611585b8945a5 /dev-ml
parentdev-ml/opam-solver: add 2.0.9 (diff)
downloadgentoo-2ca90f4a11fe6fb3a7d7ad8d012ee3c4fbd8cbba.tar.gz
gentoo-2ca90f4a11fe6fb3a7d7ad8d012ee3c4fbd8cbba.tar.bz2
gentoo-2ca90f4a11fe6fb3a7d7ad8d012ee3c4fbd8cbba.zip
dev-ml/opam-installer: add 2.0.9
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/opam-installer/Manifest1
-rw-r--r--dev-ml/opam-installer/opam-installer-2.0.9.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-ml/opam-installer/Manifest b/dev-ml/opam-installer/Manifest
index bf62be30f707..d6e4ebdb9a8f 100644
--- a/dev-ml/opam-installer/Manifest
+++ b/dev-ml/opam-installer/Manifest
@@ -1 +1,2 @@
DIST opam-full-2.0.8.tar.gz 8006252 BLAKE2B 26348bdbb8bdc2fbf9d736286c1f4134ce065e8c15e34d51c8d2c6e5338fd6db089df38a19b07cde70770724fc4cc3dbd9e7d75628e5435ca8a2f8c0d4d3f2f0 SHA512 f08893ad0c1e124368168f28dcb5c3293e443da712d7b12db432c21ff72f7e1440bcc7156f49661d286360a16dcd166d3d02ecdebf8b1cda7c7df2b22e48f80f
+DIST opam-full-2.0.9.tar.gz 8029605 BLAKE2B c2ae06bdbbdbe9db270ec0027ec8d13a228f0af2ae5089476fa3a698d27e1f47abf2e3a15ecc9ca610717ba6b979b4ca76cce56c52f6592ae789b88fb5e5b68d SHA512 9f44d878a2599a876f5e5b9b7457b6f446a5e59156ed3d449dcc29e40c44df8b69da619eabdf030e45526fba4bd9a00c65dec2c36552d2e03788596b0aceee85
diff --git a/dev-ml/opam-installer/opam-installer-2.0.9.ebuild b/dev-ml/opam-installer/opam-installer-2.0.9.ebuild
new file mode 100644
index 000000000000..a2b88905a299
--- /dev/null
+++ b/dev-ml/opam-installer/opam-installer-2.0.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# We are opam
+OPAM_INSTALLER_DEP=" "
+OPAM_SKIP_VALIDATION=yes
+inherit opam
+
+DESCRIPTION="Core installer for opam packages"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/releases/download/${PV}/opam-full-${PV}.tar.gz"
+S="${WORKDIR}/opam-full-${PV/_/-}"
+OPAM_INSTALLER="${S}/opam-installer"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+# Cherry-picked from https://deb.debian.org/debian/pool/main/o/opam/opam_2.0.8-1.debian.tar.xz
+PATCHES=( "${FILESDIR}/debian-Port-to-Dose3-6.0.1.patch" )
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02.3
+ dev-ml/cmdliner:=
+ ~dev-ml/opam-format-${PV}
+ >=dev-ml/dose3-6
+"
+DEPEND="${RDEPEND}
+ dev-ml/findlib"
+
+src_configure() {
+ econf \
+ --prefix="${EPREFIX}/usr" \
+ --with-mccs \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --mandir="${EPREFIX}/usr/share/man"
+}
+
+src_compile() {
+ sed -e 's/DUNE = .*$/DUNE = /' -i Makefile.config
+ #passing -jX to the dune build leads to errors
+ #see: https://github.com/ocaml/opam/issues/3585
+ emake DUNE_PROMOTE_ARG="" -j1
+}