summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorHank Leininger <hlein@korelogic.com>2020-08-02 16:11:07 -0600
committerSam James <sam@gentoo.org>2020-08-14 23:23:32 +0000
commit3bfdfabacefb21ca771607bc84b295389b4468cf (patch)
tree820e9aeaa14f1db66a89a755c251a3c0ab5c32b8 /dev-ml
parentdev-python/sphinx: Drop superfluous python_gen_cond_dep w/o python2_7 (diff)
downloadgentoo-3bfdfabacefb21ca771607bc84b295389b4468cf.tar.gz
gentoo-3bfdfabacefb21ca771607bc84b295389b4468cf.tar.bz2
gentoo-3bfdfabacefb21ca771607bc84b295389b4468cf.zip
dev-ml/ocaml-gettext: ocaml-4.09 compat fixes
Existing ebuild will not build with ocaml-4.09, only with older versions that have an outstanding GLSA (202007-48). ocaml-4.09 is being stabilized now. This commit just uses the existing workaround/fix in b.g.o and updates the ebuild to EAPI=7. Updated to address feedback in https://github.com/gentoo/gentoo/pull/16964 Signed-off-by: Hank Leininger <hlein@korelogic.com> Closes: https://bugs.gentoo.org/731302 Bug: https://bugs.gentoo.org/708696 Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-gettext/files/ocaml-unsafe-string.patch17
-rw-r--r--dev-ml/ocaml-gettext/ocaml-gettext-0.3.7-r1.ebuild59
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-ml/ocaml-gettext/files/ocaml-unsafe-string.patch b/dev-ml/ocaml-gettext/files/ocaml-unsafe-string.patch
new file mode 100644
index 000000000000..8d0a12c80d0e
--- /dev/null
+++ b/dev-ml/ocaml-gettext/files/ocaml-unsafe-string.patch
@@ -0,0 +1,17 @@
+diff --git a/ConfMakefile.in b/ConfMakefile.in
+index 5a1e9ea..b562698 100644
+--- a/ConfMakefile.in
++++ b/ConfMakefile.in
+@@ -37,9 +37,9 @@ OCAMLLIB=@OCAMLLIB@
+ OCAMLFIND_COMMANDS = "ocamlc=@OCAMLC@ \
+ ocamlopt=@OCAMLOPT@ \
+ ocamldep=@OCAMLDEP@"
+-OCAMLC = @OCAMLFIND@ ocamlc
+-OCAMLOPT = @OCAMLFIND@ ocamlopt
+-OCAMLDEP = @OCAMLFIND@ ocamldep
++OCAMLC = @OCAMLFIND@ ocamlc -unsafe-string
++OCAMLOPT = @OCAMLFIND@ ocamlopt -unsafe-string
++OCAMLDEP = @OCAMLFIND@ ocamldep -unsafe-string
+ OCAMLBEST = @OCAMLBEST@
+ OCAMLVERSION = @OCAMLVERSION@
+ OCAMLFIND = @OCAMLFIND@
diff --git a/dev-ml/ocaml-gettext/ocaml-gettext-0.3.7-r1.ebuild b/dev-ml/ocaml-gettext/ocaml-gettext-0.3.7-r1.ebuild
new file mode 100644
index 000000000000..c4643c7c33ae
--- /dev/null
+++ b/dev-ml/ocaml-gettext/ocaml-gettext-0.3.7-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib eutils autotools
+
+DESCRIPTION="Provides support for internationalization of OCaml program"
+HOMEPAGE="https://github.com/gildor478/ocaml-gettext"
+SRC_URI="https://github.com/gildor478/ocaml-gettext/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+PATCHES=( "${FILESDIR}"/ocaml-unsafe-string.patch )
+
+RDEPEND=">=dev-lang/ocaml-3.12.1:=
+ >=dev-ml/ocaml-fileutils-0.4.0:=
+ >=dev-ml/camomile-0.8.3:=
+ sys-devel/gettext
+ dev-ml/camlp4:=
+"
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ )
+ test? ( dev-ml/ounit )
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-docbook-stylesheet="${EPREFIX}/usr/share/sgml/docbook/xsl-stylesheets/" \
+ $(use_enable doc) \
+ $(use_enable test)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ findlib_src_preinst
+ emake -j1 DESTDIR="${D}" \
+ BINDIR="${ED}/usr/bin" \
+ PODIR="${ED}/usr/share/locale/" \
+ DOCDIR="${ED}/usr/share/doc/${PF}" \
+ MANDIR="${ED}/usr/share/man" \
+ install
+ dodoc CHANGELOG README THANKS TODO
+}