summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-12 06:57:10 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-12 07:46:25 +0200
commit3d64e6504d59d6e32d256deb5c2300a7b3e3c3d6 (patch)
treeacb551cceb4714bb4e17f20b42c69b1024a91f3a /dev-ml
parentdev-ml/ocaml-sqlite3: bump to 4.1.3 (diff)
downloadgentoo-3d64e6504d59d6e32d256deb5c2300a7b3e3c3d6.tar.gz
gentoo-3d64e6504d59d6e32d256deb5c2300a7b3e3c3d6.tar.bz2
gentoo-3d64e6504d59d6e32d256deb5c2300a7b3e3c3d6.zip
dev-ml/ocaml-cstruct: bump to 3.0.1
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-cstruct/Manifest1
-rw-r--r--dev-ml/ocaml-cstruct/ocaml-cstruct-3.0.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-ml/ocaml-cstruct/Manifest b/dev-ml/ocaml-cstruct/Manifest
index 2199b1622cde..011727523f13 100644
--- a/dev-ml/ocaml-cstruct/Manifest
+++ b/dev-ml/ocaml-cstruct/Manifest
@@ -1,3 +1,4 @@
DIST ocaml-cstruct-2.4.0.tar.gz 259372 SHA256 a3e19e6a57204a5172c9ed0abd5153d85925b2d32f5ae51a53868a287be647fb SHA512 c37d16605f929aeeda33166183dcbe6b8e367583a8b25fde1bb5a4f9141a11f93e6f5463a500907d8829cb285075a8d2ca7874618a92f817997f76258175cbb3 WHIRLPOOL 8812fff7e3cc2a715e8ba395ab852752c0cf28bf8828e61de3f01b52ffabbc61c13c05b03fc964d1f68e88f33ce08c18b44a070881d3b876283fb987b945c664
DIST ocaml-cstruct-2.4.1.tar.gz 259399 SHA256 f3c1600e85eb93a58c052e2e9575b48d4dd02784d9b2615dadf861860afa1ee7 SHA512 30c541e50dc221d3d8df54f9a8dfa1f88b10f49b276779f7355a38effdfe048de0300bfcc7e361715f63b696d42bd11aa120df6b4058d3b24962777e91b1633e WHIRLPOOL 40d1fcf4674ee47595f14583f964850b4e2b8747f788efb947994ae5b59e12115c381afa7ccc269b408df2b0eed1e02967e83a6fa256aca8926401e6b3e0ed75
DIST ocaml-cstruct-3.0.0.tar.gz 205070 SHA256 b420548a2e286dc9a8c8aed7fd142879b97177a76ad69c6e237df2bb5368a69b SHA512 9b080801e7d714412f4c4e417a90df5e412a69ed7a5c88e83f4212e287bf5687b0585a2f9f6849f254322a0c5d0ed98fba2ebe1b19a5c9d198435efe2a7f38a0 WHIRLPOOL 564332813d55284f6ca84b4d8bd1d93dc0484a21b052c4009162b3c4be5fc104c3c15b9e4f7ed467226cacfe8bbf70d5f827c335a165d6c68fd3946e073b91a7
+DIST ocaml-cstruct-3.0.1.tar.gz 205663 SHA256 1e1c731c8970a82f5947ab0ee73ec2d160df3cd0f5e752a25c2689448e13a7e2 SHA512 355f97f1b3a6e7812b9210e348e4544e0ae6f01bef6536808cdcfe32153f9e3b711d1e869990cbd0205d433a51c7463c10f410b59aae33c32dab7f35f5413c27 WHIRLPOOL 54daaf26d0882fd7c782102c0fb84f683497a6acfee04649e19b9c5c330d24192e710fcbf8dede9b5128474fa314109a87894d99b6f44349dbbca52a68f7a10b
diff --git a/dev-ml/ocaml-cstruct/ocaml-cstruct-3.0.1.ebuild b/dev-ml/ocaml-cstruct/ocaml-cstruct-3.0.1.ebuild
new file mode 100644
index 000000000000..1c5b40081f27
--- /dev/null
+++ b/dev-ml/ocaml-cstruct/ocaml-cstruct-3.0.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Map OCaml arrays onto C-like structs"
+HOMEPAGE="https://github.com/mirage/ocaml-cstruct https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="async +lwt +ppx test"
+
+RDEPEND="
+ async? ( dev-ml/async:= )
+ lwt? ( dev-ml/lwt:= )
+ ppx? (
+ dev-ml/ppx_tools:=
+ dev-ml/ocaml-migrate-parsetree:=
+ >=dev-ml/ppx_tools_versioned-5.0.1:=
+ )
+ >=dev-lang/ocaml-4.01:=
+ dev-ml/ocplib-endian:=
+ dev-ml/sexplib:=
+ dev-ml/type-conv:=
+"
+DEPEND="
+ dev-ml/jbuilder
+ dev-ml/opam
+ test? ( dev-ml/ounit )
+ ${RDEPEND}
+"
+
+oinstall() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${1}.install || die
+}
+
+src_install() {
+ oinstall cstruct
+ oinstall cstruct-unix
+ use lwt && oinstall cstruct-lwt
+ use async && oinstall cstruct-async
+ use ppx && oinstall ppx_cstruct
+}