summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-12-16 11:08:42 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-12-16 12:06:38 +0100
commit45374895163ae857890ef482fb2693b16781020f (patch)
tree91c3b9d6441a49307c8785a405b2e69f198a398c /dev-ml
parentsci-libs/NNPACK: PythonHasVersionUsage (diff)
downloadgentoo-45374895163ae857890ef482fb2693b16781020f.tar.gz
gentoo-45374895163ae857890ef482fb2693b16781020f.tar.bz2
gentoo-45374895163ae857890ef482fb2693b16781020f.zip
dev-ml/topkg: bump to 1.0.6
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/topkg/Manifest1
-rw-r--r--dev-ml/topkg/topkg-1.0.6.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/topkg/Manifest b/dev-ml/topkg/Manifest
index a5a2f2786db5..a7e7d9253d05 100644
--- a/dev-ml/topkg/Manifest
+++ b/dev-ml/topkg/Manifest
@@ -1,2 +1,3 @@
DIST topkg-1.0.3.tar.gz 122302 BLAKE2B c3c583fe6d9c6602c9eeae6ba76f0b8e1eda754cb2ffed8f6a9b51eeea53a2d16ad0af5bf3bf1f257233481efd1e7fecfca7185773dcb4258f6a0a8195aaf61f SHA512 b4f3393b142c5c2d71bb4a25f5af020831bd48ad5c354b68cf5a2df2044b534024f0568da93ad26ca383c97ba4277b4878dba7ce9267146f3805c67f52950cbf
DIST topkg-1.0.5.tar.gz 123508 BLAKE2B b6090143659607fb65257adfc78f6c12782cf4cca99e5d997a2e324196cc19689b95b1412296feba410ce894d559e92d1f2c417ce46b441ad499a94264ffff99 SHA512 ea220df58ba3727281392b335377f9cea1cf1539ee86f2947faf1ccbcf36714fa40fbc06516867852d5992ca5840778467a02a0fe67369725da95eb442e4269a
+DIST topkg-1.0.6.tar.gz 123588 BLAKE2B 49637d7ea34e243e0263a1a1cde2b3fc642325ac43f8c46d05c15a82bef9a117522e8a663c02bb8406b0a3d23b973ffc80e276aae4b316aa49f188ef5af919ee SHA512 560eb074d51824b02fb76223c2a16eefbf3bc1107c0c228b4e8491d2433e0b22e1b750ea63944f5653ab4e3e566a72c939cef6a8207e156874d6dad2b9c8ca99
diff --git a/dev-ml/topkg/topkg-1.0.6.ebuild b/dev-ml/topkg/topkg-1.0.6.ebuild
new file mode 100644
index 000000000000..e6250c896d63
--- /dev/null
+++ b/dev-ml/topkg/topkg-1.0.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit findlib
+
+DESCRIPTION="The transitory OCaml software packager"
+HOMEPAGE="http://erratique.ch/software/topkg https://github.com/dbuenzli/topkg"
+SRC_URI="https://github.com/dbuenzli/topkg/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="dev-ml/result:=
+ dev-ml/ocamlbuild:=
+ dev-ml/findlib:=
+ dev-lang/ocaml:=[ocamlopt?]"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ ocaml pkg/pkg.ml build --pkg-name ${PN} || die
+}
+
+src_install() {
+ # Can't use opam-installer here as it is an opam dep...
+ findlib_src_preinst
+
+ local nativelibs
+ if use ocamlopt; then
+ nativelibs=$(echo _build/src/${PN}*.cm{x,xa,xs,ti} _build/src/${PN}.a)
+ fi
+
+ ocamlfind install ${PN} _build/pkg/META _build/src/${PN}.mli _build/src/${PN}.cm{a,i} ${nativelibs} || die
+ dodoc CHANGES.md DEVEL.md README.md
+}