summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-05-01 20:50:00 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-05-03 11:13:52 +0200
commit4a549b86ac3a26dcc959c6d78534c7e5c50aa7f8 (patch)
tree4f38a54d6ea5a74ccc0377fa2e856fea8c064f05 /dev-ml
parentdev-ml/js_of_ocaml: fix build with ocaml 4.03 (diff)
downloadgentoo-4a549b86ac3a26dcc959c6d78534c7e5c50aa7f8.tar.gz
gentoo-4a549b86ac3a26dcc959c6d78534c7e5c50aa7f8.tar.bz2
gentoo-4a549b86ac3a26dcc959c6d78534c7e5c50aa7f8.zip
dev-ml/pxp: fix build with ocaml 4.03
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/pxp/files/oc43.patch13
-rw-r--r--dev-ml/pxp/pxp-1.2.8.ebuild4
2 files changed, 17 insertions, 0 deletions
diff --git a/dev-ml/pxp/files/oc43.patch b/dev-ml/pxp/files/oc43.patch
new file mode 100644
index 000000000000..0168c703d06d
--- /dev/null
+++ b/dev-ml/pxp/files/oc43.patch
@@ -0,0 +1,13 @@
+Index: pxp-1.2.8/src/pxp-engine/pxp_document.ml
+===================================================================
+--- pxp-1.2.8.orig/src/pxp-engine/pxp_document.ml
++++ pxp-1.2.8/src/pxp-engine/pxp_document.ml
+@@ -3398,8 +3398,6 @@ let find_all_elements ?deeply eltype bas
+ ;;
+
+
+-exception Skip;;
+-
+ let map_tree ~pre ?(post=(fun x -> x)) base =
+ let rec map_rec n =
+ let n' = pre n in
diff --git a/dev-ml/pxp/pxp-1.2.8.ebuild b/dev-ml/pxp/pxp-1.2.8.ebuild
index 0e272ed607b0..77edb0055c3a 100644
--- a/dev-ml/pxp/pxp-1.2.8.ebuild
+++ b/dev-ml/pxp/pxp-1.2.8.ebuild
@@ -27,6 +27,10 @@ IUSE="examples +ocamlopt"
S=${WORKDIR}/${MY_P}
+src_prepare() {
+ epatch "${FILESDIR}/oc43.patch"
+}
+
src_configure() {
#the included configure does not support many standard switches and is quite picky
./configure || die "configure failed"