summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-06-10 15:57:32 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-06-10 19:34:36 +0200
commit4c743a6118536a5e82064789180792a53b2a97c6 (patch)
treece72bc214888b1778d701bcb2f10582d0046d773 /dev-ml
parentapp-emacs/repology: new package; add 1.2.3 (diff)
downloadgentoo-4c743a6118536a5e82064789180792a53b2a97c6.tar.gz
gentoo-4c743a6118536a5e82064789180792a53b2a97c6.tar.bz2
gentoo-4c743a6118536a5e82064789180792a53b2a97c6.zip
dev-ml/luv: bump to 0.5.12
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/luv/Manifest1
-rw-r--r--dev-ml/luv/luv-0.5.12.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-ml/luv/Manifest b/dev-ml/luv/Manifest
index f8856bf634c9..4e50b015b4b7 100644
--- a/dev-ml/luv/Manifest
+++ b/dev-ml/luv/Manifest
@@ -1,2 +1,3 @@
DIST luv-0.5.10.tar.gz 805333 BLAKE2B 23edd2bc870a2886e560d330d9a20b205a77ea7bc8ed631e00e43819474eeb75246b407113b59ed9c5f74462ad5f721338ac5a157a1fe0e443abf9ff88771089 SHA512 c50a0def366944b4ef6038503ecefe75d8e45f542311198531f01a355675c08b00370480141b455616429a883c3232d34628e6a67846db5864a1b0eabfe6311f
DIST luv-0.5.11.tar.gz 809549 BLAKE2B 932bf48cb2d9ca32777d3c3d7457db5f4fb9dbfd51a8efbdf9282a9ebd941c53c56d7c17cf5e502c0e742dea1d1d76623d4adad32476fb36a0c08efded331f98 SHA512 8d1d7842583b02b906d89fe14bda5a66809d8ef7185efbe95e0fe7df619b795ad89fcbf16bfe1c3e92cef8721fe3d4e6192cabe215f3fe13b33de7335783e5f3
+DIST luv-0.5.12.tar.gz 817528 BLAKE2B b61cea1bc3446a4c52a80712f430e40007d260e59562f1add7518bb03c51689df76e9c6240fc4dba230bf19459980d2acda4f6710f9895c7f4bd5617a1f2ec38 SHA512 c5213914a43e83ba879b068aa59d5bf0d86f36bd880a5adee45d301d41e7371954e426f50338deda3f0e5c66104c789d3dbc666ebabbe340ba0b76c561e909e1
diff --git a/dev-ml/luv/luv-0.5.12.ebuild b/dev-ml/luv/luv-0.5.12.ebuild
new file mode 100644
index 000000000000..c0f3ea51305e
--- /dev/null
+++ b/dev-ml/luv/luv-0.5.12.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Binding to libuv: cross-platform asynchronous I/O"
+HOMEPAGE="https://github.com/aantron/luv"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/aantron/${PN}.git"
+else
+ SRC_URI="https://github.com/aantron/${PN}/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-lang/ocaml:=[ocamlopt?]
+ dev-libs/libuv:=
+ dev-ml/ocaml-ctypes:=[ocamlopt?]
+ dev-ml/result:=[ocamlopt?]
+ dev-ml/integers:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gnuconfig
+ test? ( dev-ml/alcotest[ocamlopt?] )
+"
+
+src_prepare() {
+ default
+
+ cp "${BROOT}"/usr/share/gnuconfig/config.{guess,sub} src/c/vendor/configure/ || die
+}
+
+src_compile() {
+ LUV_USE_SYSTEM_LIBUV=yes dune_src_compile
+}