summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-10-06 14:57:24 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-10-06 15:11:14 +0200
commit513a48573bc1e7a96b13ed28cde0621b526840f4 (patch)
tree1649f35cb07edd451ca6a13ce21d30797c7d30c2 /dev-ml
parentdev-vcs/mercurial: License is GPL-2+ (diff)
downloadgentoo-513a48573bc1e7a96b13ed28cde0621b526840f4.tar.gz
gentoo-513a48573bc1e7a96b13ed28cde0621b526840f4.tar.bz2
gentoo-513a48573bc1e7a96b13ed28cde0621b526840f4.zip
dev-ml/capnp-ocaml: bump to 3.1.0
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/capnp-ocaml/Manifest1
-rw-r--r--dev-ml/capnp-ocaml/capnp-ocaml-3.1.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/capnp-ocaml/Manifest b/dev-ml/capnp-ocaml/Manifest
index 6f6ea01245dd..affb53e10a0b 100644
--- a/dev-ml/capnp-ocaml/Manifest
+++ b/dev-ml/capnp-ocaml/Manifest
@@ -1 +1,2 @@
DIST capnp-ocaml-3.0.0.tar.gz 140985 SHA256 01b5380d4d4ec5392c91036787d93a553055ad403ff41d2cf73caff25a9098cc SHA512 5cdf678fa80e67c552f60123f1d04eb5facad81e6c29661c2234c06bbcb98312d1eba96f81f3e747fef0b4de986aff07b69aafcbfde60873ba40452a66d75075 WHIRLPOOL 2b6f04034c81dd0d01089b3ff39c681dab98a665ade944ca5d21014bb2d61b5bcaa4e4545e65d2829e9a837b44423cca580e7c6ca87a62d55c33e81caf859e3e
+DIST capnp-ocaml-3.1.0.tar.gz 141189 SHA256 59b7d4a8e87c0b492e51bd53dde9571f25e8fdf328dd458fa14aff39374346d5 SHA512 d3a24800ee334d5d0506a9b9f2db10994e475b205e347ae606d4f963cd846c7ab2ed8f60505495509cf2f3444c46b8aefe0501c6803874b5659b8b6429506b77 WHIRLPOOL 9d744b18ff9a7997b9f3e230e1fc188cb971bffcf5e87616ce05e6b87c12dcf42c568ed5ec004a0dac670e9b38f8a04672edb244d8a74ca78f9cb07285c91b3e
diff --git a/dev-ml/capnp-ocaml/capnp-ocaml-3.1.0.ebuild b/dev-ml/capnp-ocaml/capnp-ocaml-3.1.0.ebuild
new file mode 100644
index 000000000000..4d060a2a99a2
--- /dev/null
+++ b/dev-ml/capnp-ocaml/capnp-ocaml-3.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit opam
+
+DESCRIPTION="OCaml code generator plugin for the Cap'n Proto serialization framework"
+HOMEPAGE="https://github.com/pelzlpj/capnp-ocaml"
+SRC_URI="https://github.com/pelzlpj/capnp-ocaml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-ml/core_kernel:=
+ dev-ml/ocaml-extunix:=
+ dev-ml/ocplib-endian:=
+ dev-ml/res:=
+ dev-ml/ocaml-uint:=
+ dev-libs/capnproto:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/core:= dev-ml/ounit )
+ dev-ml/jbuilder
+"
+
+src_compile() {
+ emake build
+}
+
+src_install() {
+ opam_src_install capnp
+}