summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-06 16:33:29 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-06 16:39:11 +0100
commit555d2144ffdac351bab4b7f67a8a2e832a2ca659 (patch)
tree28ac1bf73280add010a0e100f64e4af989ed8fec /dev-ml
parentdev-ml/js_of_ocaml: add xml useflag (diff)
downloadgentoo-555d2144ffdac351bab4b7f67a8a2e832a2ca659.tar.gz
gentoo-555d2144ffdac351bab4b7f67a8a2e832a2ca659.tar.bz2
gentoo-555d2144ffdac351bab4b7f67a8a2e832a2ca659.zip
dev-ml/js_of_ocaml: add ppx useflag
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/js_of_ocaml/js_of_ocaml-2.7.ebuild4
-rw-r--r--dev-ml/js_of_ocaml/metadata.xml1
2 files changed, 4 insertions, 1 deletions
diff --git a/dev-ml/js_of_ocaml/js_of_ocaml-2.7.ebuild b/dev-ml/js_of_ocaml/js_of_ocaml-2.7.ebuild
index 060d3cace1f0..1f8b9b08f2de 100644
--- a/dev-ml/js_of_ocaml/js_of_ocaml-2.7.ebuild
+++ b/dev-ml/js_of_ocaml/js_of_ocaml-2.7.ebuild
@@ -13,13 +13,14 @@ SRC_URI="https://github.com/ocsigen/js_of_ocaml/archive/${PV}.tar.gz -> ${P}.tar
LICENSE="LGPL-2.1-with-linking-exception"
SLOT="0/${PV}"
KEYWORDS="~amd64"
-IUSE="+ocamlopt doc +deriving +react +xml X"
+IUSE="+ocamlopt doc +deriving +ppx +react +xml X"
DEPEND="
>=dev-lang/ocaml-3.12:=[ocamlopt?,X?]
>=dev-ml/lwt-2.4.4:=
react? ( dev-ml/react:= dev-ml/reactiveData:= )
xml? ( >=dev-ml/tyxml-3.6:= )
+ ppx? ( dev-ml/ppx_tools:= )
dev-ml/cmdliner:=
dev-ml/menhir:=
dev-ml/ocaml-base64:=
@@ -35,6 +36,7 @@ src_configure() {
use deriving || echo "WITH_DERIVING := NO" >> Makefile.conf
use X || echo "WITH_GRAPHICS := NO" >> Makefile.conf
use react || echo "WITH_REACT := NO" >> Makefile.conf
+ use ppx || echo "WITH_PPX := NO" >> Makefile.conf
}
src_compile() {
diff --git a/dev-ml/js_of_ocaml/metadata.xml b/dev-ml/js_of_ocaml/metadata.xml
index d3fd68ee65c8..904a7a4498e5 100644
--- a/dev-ml/js_of_ocaml/metadata.xml
+++ b/dev-ml/js_of_ocaml/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<use>
<flag name="deriving">Enable <pkg>dev-ml/deriving</pkg> support for improving the type safety.</flag>
+ <flag name="ppx">Enables the ppx syntax extension</flag>
<flag name="react">Enable functionnal reactive programming support.</flag>
</use>
<upstream>