summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-12-26 15:02:21 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-12-26 16:11:46 +0100
commit5763e2211bebc3a0a48aa6bb6d8c8773b906fc18 (patch)
tree28276ccf6bc8b479efbb3d0ba58e9952b3b40df9 /dev-ml
parentdev-ml/sequence: bump to 0.9 (diff)
downloadgentoo-5763e2211bebc3a0a48aa6bb6d8c8773b906fc18.tar.gz
gentoo-5763e2211bebc3a0a48aa6bb6d8c8773b906fc18.tar.bz2
gentoo-5763e2211bebc3a0a48aa6bb6d8c8773b906fc18.zip
dev-ml/ocaml-containers: fix build with sequence 0.9
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-containers/files/seq.patch13
-rw-r--r--dev-ml/ocaml-containers/ocaml-containers-0.22.ebuild4
2 files changed, 16 insertions, 1 deletions
diff --git a/dev-ml/ocaml-containers/files/seq.patch b/dev-ml/ocaml-containers/files/seq.patch
new file mode 100644
index 000000000000..2ba116e3441e
--- /dev/null
+++ b/dev-ml/ocaml-containers/files/seq.patch
@@ -0,0 +1,13 @@
+Index: ocaml-containers-0.22/src/advanced/CCLinq.ml
+===================================================================
+--- ocaml-containers-0.22.orig/src/advanced/CCLinq.ml
++++ ocaml-containers-0.22/src/advanced/CCLinq.ml
+@@ -212,7 +212,7 @@ module PMap = struct
+ seq
+
+ let flatten_l m =
+- let seq = Sequence.flatMap
++ let seq = Sequence.flat_map
+ (fun (k,v) -> Sequence.map (fun v' -> k,v') (Sequence.of_list v))
+ m.to_seq
+ in
diff --git a/dev-ml/ocaml-containers/ocaml-containers-0.22.ebuild b/dev-ml/ocaml-containers/ocaml-containers-0.22.ebuild
index 27d31ce576af..29bae80d254b 100644
--- a/dev-ml/ocaml-containers/ocaml-containers-0.22.ebuild
+++ b/dev-ml/ocaml-containers/ocaml-containers-0.22.ebuild
@@ -20,11 +20,13 @@ IUSE="test"
RDEPEND="
dev-ml/result:=
- dev-ml/sequence:=
+ >=dev-ml/sequence-0.9:=
"
DEPEND="${RDEPEND} dev-ml/cppo
test? ( dev-ml/iTeML )"
+PATCHES=( "${FILESDIR}/seq.patch" )
+
src_configure() {
oasis_configure_opts="
--enable-unix