summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-12-19 11:17:56 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-12-19 13:07:26 +0100
commit5a67ee69e150815355d26187f335b33890f4de50 (patch)
tree5e38c79f113eb43ce443f227b628ce16ac5138aa /dev-ml
parentdev-ml/ocaml-containers: remove old (diff)
downloadgentoo-5a67ee69e150815355d26187f335b33890f4de50.tar.gz
gentoo-5a67ee69e150815355d26187f335b33890f4de50.tar.bz2
gentoo-5a67ee69e150815355d26187f335b33890f4de50.zip
dev-ml/ocaml-containers: bump to 0.22
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-containers/Manifest1
-rw-r--r--dev-ml/ocaml-containers/ocaml-containers-0.22.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/ocaml-containers/Manifest b/dev-ml/ocaml-containers/Manifest
index 63856894255a..fb10d42b8c99 100644
--- a/dev-ml/ocaml-containers/Manifest
+++ b/dev-ml/ocaml-containers/Manifest
@@ -1 +1,2 @@
DIST ocaml-containers-0.21.tar.gz 429430 SHA256 7b3395964e527a60cfc3c96354c4ba1ebb9996e6f83399a31dd58eb053fd777b SHA512 fd339b09296245d40eac7661468147c98c45cdfc882ac890ca9a903f3a4abb21d4d13981b9784710d317ef4b3f76c3141b322df78673df2e0108d20cb633ae84 WHIRLPOOL 5cdd686f4d1b2b33ecc401b569a9321bc639b5c83866b5954585b021ecadb72e2a2b66eca778e6d5b0105f2c613d7df2cc3e20f2c1b44db622a03f7bf9068f9e
+DIST ocaml-containers-0.22.tar.gz 429678 SHA256 883e64a6b2275355086521a67d5fe0e436bbf79f54c8fb068a05ab3cf3408e98 SHA512 1454f8bcd11d02a9efd2fe223e2db591d2e1d66df6877af920b4d8a2cc3a2c6b34b0979069015565618700dfb4a74d6a8f2d8cd8f9fc6fa7888331320ea41c46 WHIRLPOOL f5993d629fe2a803b1284cd5794f3345060215cf16bb97347dd2173b7015735ddcd43b98c3b5ccf365d372ffedf77892e862fbc276b24468699a95492dc784e7
diff --git a/dev-ml/ocaml-containers/ocaml-containers-0.22.ebuild b/dev-ml/ocaml-containers/ocaml-containers-0.22.ebuild
new file mode 100644
index 000000000000..27d31ce576af
--- /dev/null
+++ b/dev-ml/ocaml-containers/ocaml-containers-0.22.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="A modular standard library focused on data structures"
+HOMEPAGE="https://github.com/c-cube/ocaml-containers"
+SRC_URI="https://github.com/c-cube/ocaml-containers/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-ml/result:=
+ dev-ml/sequence:=
+"
+DEPEND="${RDEPEND} dev-ml/cppo
+ test? ( dev-ml/iTeML )"
+
+src_configure() {
+ oasis_configure_opts="
+ --enable-unix
+ --disable-bench
+ " oasis_src_configure
+}