summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-27 12:44:59 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-27 12:44:59 +0200
commit6cbd5e8b25ee9de62832bed16cb94c190f2ce7ab (patch)
tree158edadee06ee62c9496165a6d6337c435e0137e /dev-ml
parentdev-ml/flow_parser: add remoteid (diff)
downloadgentoo-6cbd5e8b25ee9de62832bed16cb94c190f2ce7ab.tar.gz
gentoo-6cbd5e8b25ee9de62832bed16cb94c190f2ce7ab.tar.bz2
gentoo-6cbd5e8b25ee9de62832bed16cb94c190f2ce7ab.zip
dev-ml/flow_parser: bump to 0.44.1
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/flow_parser/Manifest1
-rw-r--r--dev-ml/flow_parser/flow_parser-0.44.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/flow_parser/Manifest b/dev-ml/flow_parser/Manifest
index ed2d60330aae..e02c0fb60c1f 100644
--- a/dev-ml/flow_parser/Manifest
+++ b/dev-ml/flow_parser/Manifest
@@ -1 +1,2 @@
DIST flow-0.44.0.tar.gz 2435252 SHA256 5c20a20c500e2a29dbe2b53ecc0c4a5172c849417c8bff32b2fa478703bf382f SHA512 30b1149229fd85f71426330d848d2c085543f08d7ceeafcc4b477ec3ff978ff7b5d9580d3cc3856b7e8e5ab9afa667552ff148fee9dbf845278d60bf1918976d WHIRLPOOL d71af4d60cac7d64e42b6abc6a6be3fefc530bfd024779fd3864e21b40fb3d460fc13fca1a64afe31a544d047eed4b33fde976870ef359190e04c6032ad11f36
+DIST flow-0.44.1.tar.gz 2435277 SHA256 2dbe1c863ea8c594dfde8e2924b32033336f31f039d61ab07e276467195c2028 SHA512 56256c9a681dae050bed6b5822c6b57e0f5e7c5db0e850ad97f1fa8da5300494eea91a2b7a5fda1c702431c6d36da54bddf761b69332e0e6d3d5fd87f38208aa WHIRLPOOL 9737c61de732b0073b9b46adc6d558f35c06245f3d71527e92ba2e00a9aef28580cf9d87776e965e42956cf58416c2c2f3356e30db323aae45a4486287c0d547
diff --git a/dev-ml/flow_parser/flow_parser-0.44.1.ebuild b/dev-ml/flow_parser/flow_parser-0.44.1.ebuild
new file mode 100644
index 000000000000..8460f51ef8ba
--- /dev/null
+++ b/dev-ml/flow_parser/flow_parser-0.44.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="JavaScript parser written in OCaml"
+HOMEPAGE="https://github.com/facebook/flow/tree/master/src/parser"
+SRC_URI="https://github.com/facebook/flow/archive/v${PV}.tar.gz -> flow-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-lang/ocaml:="
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/ocamlbuild"
+
+S="${WORKDIR}/flow-${PV}/src/parser"
+
+src_compile() {
+ ocamlbuild parser_flow.cma parser_flow.cmxa || die
+}
+
+src_test() {
+ emake test-ocaml
+}
+
+src_install() {
+ findlib_src_preinst
+ emake ocamlfind-install
+ dodoc README.md
+}