summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-15 17:51:51 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-15 23:56:25 +0200
commit6d4d849911148ee9a0b22877f29c6540ccaa2f60 (patch)
tree856c6f2b5eec64602e3ce03b60c03ba0bfb4a2a3 /dev-ml
parentdev-ml/ocaml-cstruct: remove old (diff)
downloadgentoo-6d4d849911148ee9a0b22877f29c6540ccaa2f60.tar.gz
gentoo-6d4d849911148ee9a0b22877f29c6540ccaa2f60.tar.bz2
gentoo-6d4d849911148ee9a0b22877f29c6540ccaa2f60.zip
dev-ml/ocaml-cstruct: bump to 3.0.2
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-cstruct/Manifest1
-rw-r--r--dev-ml/ocaml-cstruct/ocaml-cstruct-3.0.2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-ml/ocaml-cstruct/Manifest b/dev-ml/ocaml-cstruct/Manifest
index 2e3a60810857..8476b9ebf6e7 100644
--- a/dev-ml/ocaml-cstruct/Manifest
+++ b/dev-ml/ocaml-cstruct/Manifest
@@ -1 +1,2 @@
DIST ocaml-cstruct-3.0.1.tar.gz 205663 SHA256 1e1c731c8970a82f5947ab0ee73ec2d160df3cd0f5e752a25c2689448e13a7e2 SHA512 355f97f1b3a6e7812b9210e348e4544e0ae6f01bef6536808cdcfe32153f9e3b711d1e869990cbd0205d433a51c7463c10f410b59aae33c32dab7f35f5413c27 WHIRLPOOL 54daaf26d0882fd7c782102c0fb84f683497a6acfee04649e19b9c5c330d24192e710fcbf8dede9b5128474fa314109a87894d99b6f44349dbbca52a68f7a10b
+DIST ocaml-cstruct-3.0.2.tar.gz 205713 SHA256 86dc71140eae007c540cec982211ef48ec776232f2b23dd0b639e0e82099d60b SHA512 041ff15c102036f1162a870534e4bf83477f988344cbf420d21cf589100ba8f2fa2ae5c7de7c16ef36e88a10d6bfac43f3a63c929b6d6d90ae12ad0027d1c76d WHIRLPOOL a249e394c868f916ec243e702bf3eed38fdb2a7f60649b3d1be46bbc1308b4c9a3ac9e5d58ca35726f5fa3320d1773952a8105c34725345854da6837c38c2ff2
diff --git a/dev-ml/ocaml-cstruct/ocaml-cstruct-3.0.2.ebuild b/dev-ml/ocaml-cstruct/ocaml-cstruct-3.0.2.ebuild
new file mode 100644
index 000000000000..388db7e25424
--- /dev/null
+++ b/dev-ml/ocaml-cstruct/ocaml-cstruct-3.0.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Map OCaml arrays onto C-like structs"
+HOMEPAGE="https://github.com/mirage/ocaml-cstruct https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="async +lwt +ppx test"
+
+RDEPEND="
+ async? (
+ dev-ml/async_kernel:=
+ dev-ml/async_unix:=
+ dev-ml/core_kernel:=
+ )
+ lwt? ( dev-ml/lwt:= )
+ ppx? (
+ dev-ml/ppx_tools:=
+ dev-ml/ocaml-migrate-parsetree:=
+ >=dev-ml/ppx_tools_versioned-5.0.1:=
+ )
+ >=dev-lang/ocaml-4.01:=
+ dev-ml/ocplib-endian:=
+ dev-ml/sexplib:=
+ dev-ml/type-conv:=
+"
+DEPEND="
+ dev-ml/jbuilder
+ dev-ml/opam
+ test? ( dev-ml/ounit )
+ ${RDEPEND}
+"
+
+oinstall() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${1}.install || die
+}
+
+src_install() {
+ oinstall cstruct
+ oinstall cstruct-unix
+ use lwt && oinstall cstruct-lwt
+ use async && oinstall cstruct-async
+ use ppx && oinstall ppx_cstruct
+}