summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-10-06 15:14:52 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-10-06 15:21:10 +0200
commit899b27034ad77bf7339a2e3c1cd66e9cdf791502 (patch)
tree48e9ba0d835f7c006d6561b39659142f8222bb9c /dev-ml
parentdev-perl/Date-Pcalc: Fix test failures re bug #615580 (diff)
downloadgentoo-899b27034ad77bf7339a2e3c1cd66e9cdf791502.tar.gz
gentoo-899b27034ad77bf7339a2e3c1cd66e9cdf791502.tar.bz2
gentoo-899b27034ad77bf7339a2e3c1cd66e9cdf791502.zip
dev-ml/dns: move from dev-ml/ocaml-dns to match opam name
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/dns/Manifest1
-rw-r--r--dev-ml/dns/dns-1.0.0.ebuild53
-rw-r--r--dev-ml/dns/metadata.xml11
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-ml/dns/Manifest b/dev-ml/dns/Manifest
new file mode 100644
index 000000000000..467ed0a3eec9
--- /dev/null
+++ b/dev-ml/dns/Manifest
@@ -0,0 +1 @@
+DIST ocaml-dns-1.0.0.tar.gz 99161 SHA256 823410badaf2faf54ca8a59472b0ad82c4db9fe4ef92f6809061baa826851226 SHA512 199653605e985851dcaafc94f1efeba5c261c29cd5e5f8eaebc9f7d25a05c43adcf7620efb291b22f9549f7c05f8ac3f6abfbcf40e0d7762bd2f7cd623ebcb1c WHIRLPOOL e7c26857270d92be2e8e068ac29119ef5d82d52fd739b8304e84c595d6a6e7fc11c22ed98e4a6d99a20f4e9d1d6b28dbc76c333d6b464bbd1dc4d37597cfe66c
diff --git a/dev-ml/dns/dns-1.0.0.ebuild b/dev-ml/dns/dns-1.0.0.ebuild
new file mode 100644
index 000000000000..85d9d78a23c1
--- /dev/null
+++ b/dev-ml/dns/dns-1.0.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="A pure OCaml implementation of the DNS protocol"
+HOMEPAGE="https://github.com/mirage/ocaml-dns https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ocaml-${P}.tar.gz"
+
+LICENSE="LGPL-2 LGPL-2.1-with-linking-exception ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-lang/ocaml-4:=
+ >=dev-ml/ocaml-base64-2.0.0:=
+ >=dev-ml/ocaml-cstruct-3.0.2:=[ppx]
+ dev-ml/ocaml-hashcons:=
+ >=dev-ml/ocaml-ipaddr-2.6.0:=
+ dev-ml/ocaml-re:=
+ >=dev-ml/ocaml-uri-1.7.0:=
+ dev-ml/result:=
+ !dev-ml/odns
+"
+DEPEND="
+ dev-ml/jbuilder
+ dev-ml/opam
+ ${RDEPEND}
+"
+
+# Do not work
+RESTRICT="test"
+
+S="${WORKDIR}/ocaml-${P}"
+
+src_compile() {
+ jbuilder build @install -p dns || die
+}
+
+src_test() {
+ jbuilder runtest -p dns || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ dns.install || die
+}
diff --git a/dev-ml/dns/metadata.xml b/dev-ml/dns/metadata.xml
new file mode 100644
index 000000000000..2f4ef14adaa5
--- /dev/null
+++ b/dev-ml/dns/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mirage/ocaml-dns</remote-id>
+ </upstream>
+</pkgmetadata>