summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-24 10:05:20 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-24 10:52:34 +0100
commit8aa6dead9bfe3293531eb2e40d01901e64e8e6e7 (patch)
treef5c4dba4b509710892eb7d327e7a7bd6a5d5406e /dev-ml
parentmedia-video/transcode: Apply transcode-1.1.7-ffmpeg29.patch when building tra... (diff)
downloadgentoo-8aa6dead9bfe3293531eb2e40d01901e64e8e6e7.tar.gz
gentoo-8aa6dead9bfe3293531eb2e40d01901e64e8e6e7.tar.bz2
gentoo-8aa6dead9bfe3293531eb2e40d01901e64e8e6e7.zip
dev-ml/ocaml-conduit: Bump to 0.15.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-conduit/Manifest1
-rw-r--r--dev-ml/ocaml-conduit/ocaml-conduit-0.15.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-ml/ocaml-conduit/Manifest b/dev-ml/ocaml-conduit/Manifest
index 56c7c8e077a9..a704e9956d11 100644
--- a/dev-ml/ocaml-conduit/Manifest
+++ b/dev-ml/ocaml-conduit/Manifest
@@ -1 +1,2 @@
DIST ocaml-conduit-0.14.5.tar.gz 38471 SHA256 00aba333c05866bb712f7890c6f9fd457b85cf592d28adc6636413032683f86f SHA512 c2de6518588e3555cd40dfc6c1ce6d809dc570ddb6a07fb8ccce1797469e9c28ea1a633d4a1b360bf15cdb95e6231ecb0be8bd44e4654baa5268f09519096b52 WHIRLPOOL 5e052d7b9d34d76662496739a6934bf64c1930ca64b2160aa8cbefe0237bd0bb3438a187c3dd05d841b7b475325afcb32bb6fb20e0b61b885c16f4b0b3259aea
+DIST ocaml-conduit-0.15.0.tar.gz 38617 SHA256 fa8c812c1e87cc59e7f6f8fd6d716014aadeda9853e5c6feacd5ecdd1fec5815 SHA512 112a09df2edc7bb0f174f19ad7d826aaf8116cce86e66182a27b4edadcffeee632d7e5cad489e9e797147b94ec81b1f1d122e9e30e384c0c84847875f9bed096 WHIRLPOOL 80bc7aa47df74c4a17c60e26bc9fd34a2167682cc63821918b33e03429f35710882a244aed61578d1e8ac7a34f67d3ba65e40754e066109b433a50868e73c243
diff --git a/dev-ml/ocaml-conduit/ocaml-conduit-0.15.0.ebuild b/dev-ml/ocaml-conduit/ocaml-conduit-0.15.0.ebuild
new file mode 100644
index 000000000000..6402be1841e6
--- /dev/null
+++ b/dev-ml/ocaml-conduit/ocaml-conduit-0.15.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Dereference URIs into communication channels for Async or Lwt"
+HOMEPAGE="https://github.com/mirage/ocaml-conduit"
+SRC_URI="https://github.com/mirage/ocaml-conduit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/sexplib:=
+ dev-ml/stringext:=
+ dev-ml/ocaml-uri:=
+ dev-ml/logs:=
+ dev-ml/ocaml-cstruct:=
+ dev-ml/ocaml-ipaddr:=
+
+ dev-ml/lwt:=
+ dev-ml/async:=
+ dev-ml/ocaml-dns:=
+ dev-ml/ocaml-ssl:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/findlib
+ dev-ml/ocamlbuild
+ dev-ml/ppx_driver
+ dev-ml/ppx_optcomp
+ dev-ml/ppx_sexp_conv
+"
+
+DOCS=( TODO.md README.md CHANGES )
+
+src_install() {
+ findlib_src_preinst
+ default
+}