summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-28 03:05:55 +0100
committerSam James <sam@gentoo.org>2021-07-28 03:05:55 +0100
commit8b4cc72a774ae098264cac469ca9aaf76b9d62dc (patch)
treeae0fe4e8acddb09a99285428e28e04040e04bdb7 /dev-ml
parentdev-ml/fpath: add 0.7.3 (diff)
downloadgentoo-8b4cc72a774ae098264cac469ca9aaf76b9d62dc.tar.gz
gentoo-8b4cc72a774ae098264cac469ca9aaf76b9d62dc.tar.bz2
gentoo-8b4cc72a774ae098264cac469ca9aaf76b9d62dc.zip
dev-ml/bos: use BDEPEND in EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/bos/bos-0.2.0.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/dev-ml/bos/bos-0.2.0.ebuild b/dev-ml/bos/bos-0.2.0.ebuild
index 48d5b1537079..f1bcc15aeb1a 100644
--- a/dev-ml/bos/bos-0.2.0.ebuild
+++ b/dev-ml/bos/bos-0.2.0.ebuild
@@ -13,20 +13,17 @@ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
-RDEPEND="
- dev-lang/ocaml:=
+RDEPEND="dev-lang/ocaml:=
dev-ml/rresult:=
dev-ml/astring:=
dev-ml/fpath:=
dev-ml/fmt:=
- dev-ml/logs:=
-"
-DEPEND="${RDEPEND}
- dev-ml/findlib
+ dev-ml/logs:="
+DEPEND="${RDEPEND}"
+BDEPEND="dev-ml/findlib
dev-ml/ocamlbuild
dev-ml/topkg
- test? ( dev-ml/mtime )
-"
+ test? ( dev-ml/mtime )"
src_compile() {
ocaml pkg/pkg.ml build --tests $(usex test true false) || die