summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-02 06:33:01 +0100
committerSam James <sam@gentoo.org>2021-10-02 06:33:01 +0100
commit9265c44748b3899317ec5b017b95eb15f78aa540 (patch)
treed711c51dccc63ffdbaeee6812c098c3a19de484e /dev-ml
parentdev-ml/ppxlib: add 0.23.0 (diff)
downloadgentoo-9265c44748b3899317ec5b017b95eb15f78aa540.tar.gz
gentoo-9265c44748b3899317ec5b017b95eb15f78aa540.tar.bz2
gentoo-9265c44748b3899317ec5b017b95eb15f78aa540.zip
dev-ml/ppxlib: add 0.23.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ppxlib/files/ppxlib-0.23.0-fix-ocaml-4.13.patch23
-rw-r--r--dev-ml/ppxlib/ppxlib-0.23.0.ebuild10
2 files changed, 26 insertions, 7 deletions
diff --git a/dev-ml/ppxlib/files/ppxlib-0.23.0-fix-ocaml-4.13.patch b/dev-ml/ppxlib/files/ppxlib-0.23.0-fix-ocaml-4.13.patch
new file mode 100644
index 000000000000..00bf6dc0e4cc
--- /dev/null
+++ b/dev-ml/ppxlib/files/ppxlib-0.23.0-fix-ocaml-4.13.patch
@@ -0,0 +1,23 @@
+https://github.com/ocaml-ppx/ppxlib/commit/ce371cfb4c2ad712cd8e9b803bbf4ef650aa5e72
+
+From: Sonja Heinze <sonjaleaheinze@gmail.com>
+Date: Fri, 10 Sep 2021 16:08:22 +0200
+Subject: [PATCH] Make our expect-test version compatible with 4.13 compiler
+
+The Warnings.parse_options function was returning a unit on older compilers
+and is returning an alert option now, but under the hood it still has the
+same side-effects.
+
+Signed-off-by: Sonja Heinze <sonjaleaheinze@gmail.com>
+--- a/test/expect/expect_test.ml
++++ b/test/expect/expect_test.ml
+@@ -63,7 +63,7 @@ let main () =
+ setup_printers ppf;
+ Topfind.log := ignore;
+
+- Warnings.parse_options false "@a-4-29-40-41-42-44-45-48-58";
++ let _ = Warnings.parse_options false "@a-4-29-40-41-42-44-45-48-58" in
+ Clflags.real_paths := false;
+ Toploop.initialize_toplevel_env ();
+
+
diff --git a/dev-ml/ppxlib/ppxlib-0.23.0.ebuild b/dev-ml/ppxlib/ppxlib-0.23.0.ebuild
index 0acf232740e3..c34f8878151c 100644
--- a/dev-ml/ppxlib/ppxlib-0.23.0.ebuild
+++ b/dev-ml/ppxlib/ppxlib-0.23.0.ebuild
@@ -38,10 +38,6 @@ DEPEND="${DEPEND}
"
BDEPEND=">=dev-ml/dune-2.8"
-src_install() {
- dune_src_install
-
- # Clashes with dev-libs/nss[utils], accidentally installed upstream
- # https://github.com/ocaml-ppx/ppxlib/issues/224
- rm "${ED}"/usr/bin/pp || die
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-ocaml-4.13.patch
+)