summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-05-10 17:19:29 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-05-10 17:19:55 +0200
commit9c224ffba495bb0d8543c1c5769087e7d7cee31d (patch)
treef317bbc53afd23948c83c4367c6a9a28dc7897cb /dev-ml
parentdev-util/idea-community: Version bump, fix versioning (diff)
downloadgentoo-9c224ffba495bb0d8543c1c5769087e7d7cee31d.tar.gz
gentoo-9c224ffba495bb0d8543c1c5769087e7d7cee31d.tar.bz2
gentoo-9c224ffba495bb0d8543c1c5769087e7d7cee31d.zip
dev-ml/opam-installer: remove building ext library (already in tree)
Closes: https://bugs.gentoo.org/787212 Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/opam-installer/opam-installer-2.0.8-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ml/opam-installer/opam-installer-2.0.8-r2.ebuild b/dev-ml/opam-installer/opam-installer-2.0.8-r2.ebuild
new file mode 100644
index 000000000000..fa67d1f64afb
--- /dev/null
+++ b/dev-ml/opam-installer/opam-installer-2.0.8-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# We are opam
+OPAM_INSTALLER_DEP=" "
+OPAM_SKIP_VALIDATION=yes
+inherit opam
+
+DESCRIPTION="Core installer for opam packages"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/releases/download/${PV}/opam-full-${PV}.tar.gz"
+S="${WORKDIR}/opam-full-${PV/_/-}"
+OPAM_INSTALLER="${S}/opam-installer"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02.3
+ dev-ml/cmdliner:=
+ ~dev-ml/opam-format-${PV}
+"
+DEPEND="${RDEPEND}
+ dev-ml/findlib"
+
+src_configure() {
+ econf \
+ --prefix="${EPREFIX}/usr" \
+ --with-mccs \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --mandir="${EPREFIX}/usr/share/man"
+}
+
+src_compile() {
+ sed -e 's/DUNE = .*$/DUNE = /' -i Makefile.config
+ #passing -jX to the dune build leads to errors
+ #see: https://github.com/ocaml/opam/issues/3585
+ emake DUNE_PROMOTE_ARG="" -j1
+}