summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-12-16 11:30:39 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-12-16 12:06:39 +0100
commita4dfc9d4c5ec1f4cf4e063cda23d7bc1209b922f (patch)
treed4659fd8ccb363487be5fbff0ea313fa682ea7ee /dev-ml
parentdev-ml/ocaml-migrate-parsetree: bump to 2.4.0 (diff)
downloadgentoo-a4dfc9d4c5ec1f4cf4e063cda23d7bc1209b922f.tar.gz
gentoo-a4dfc9d4c5ec1f4cf4e063cda23d7bc1209b922f.tar.bz2
gentoo-a4dfc9d4c5ec1f4cf4e063cda23d7bc1209b922f.zip
dev-ml/ocaml-ctypes: bump to 0.20.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-ctypes/Manifest1
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.20.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ctypes/Manifest b/dev-ml/ocaml-ctypes/Manifest
index fd32fb6a117d..5b01d819833a 100644
--- a/dev-ml/ocaml-ctypes/Manifest
+++ b/dev-ml/ocaml-ctypes/Manifest
@@ -1,3 +1,4 @@
DIST ocaml-ctypes-0.17.1.tar.gz 208101 BLAKE2B b9fe6632058a670c988ba9f1ae81b75aa5373de7231cef04d5e2ede61a44cbaa0324c04197a0a202847599a9bbe7dccd18fd3279f3f351493aaec4959caf3ada SHA512 1e197009f7e6b29b43944f757e987934337ebfa11bb2ff2ca8ba3ebc607e37cf1259d07a90d7faf4b91b49ee20d5c65357ad305f34ada0a8d336a3904233150e
DIST ocaml-ctypes-0.19.1.tar.gz 206762 BLAKE2B 29b4636e711b9b3ecf3de5d66b796d4d8ddf1109fd7b065666577ce9412e0ef3712f704729dac3b9467ac7ace8f501b90bfc1dc82b86dbe1668e5d13be46741f SHA512 cbf422a2c457b215815a04122d0522ed0f274c5927cecd25951472de6cc6fcd1151b67f95d6bbfeeb3b5f15a9fe9bdedb8861e77bd0de9902418962065e4dfc0
DIST ocaml-ctypes-0.20.0.tar.gz 206559 BLAKE2B d9bf1c3f5ae7544e3950766f7eb9bac2c9dbf84130f69b2b8807e55c6a7d659c46d9ba2227d53d578e4e49283730932213eea4c7487beffe4540432b3e700c81 SHA512 605ae95b0233f1157749475526ef00ade2f97649d06a782e8fcf97b604cb86a0dcc8f27c4ac6baec11a41b9ef5becb0e5ae55e30f1ee61b30d4ae17a0d1545c2
+DIST ocaml-ctypes-0.20.1.tar.gz 206863 BLAKE2B a101872991d4bd83464d26e79fa5052c9dadbd10da1ae734fda8976199640091939777a1ba391d2aab84d7e14fafec6f713681e2ea52f6717f5f36d26e8aa225 SHA512 f95e65ce5003a07634afcbee431cb23c54c8335f926074615fc8d76ab777b9d2fce8f75bb25bbb6ed9550a7d6237fb377aa9ad65a426d2d7e387f86c1158fe4a
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.20.1.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.20.1.ebuild
new file mode 100644
index 000000000000..3b3fce5d0eaf
--- /dev/null
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.20.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit findlib
+
+DESCRIPTION="Library for binding to C libraries using pure OCaml"
+HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes/"
+SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02:=
+ >=dev-libs/libffi-3.3_rc0:=
+ dev-ml/bigarray-compat:=
+ dev-ml/integers:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit2 dev-ml/lwt )"
+REQUIRED_USE="ocamlopt"
+
+src_prepare() {
+ sed -e 's/oUnit/ounit2/g' -i Makefile.tests || die
+ default
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ findlib_src_install
+ dodoc CHANGES.md README.md
+}