summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-10-01 20:41:15 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-10-01 20:41:15 +0200
commita9dfe8a9fc72a76428cc16daba1ab7a484a60e5c (patch)
tree6b10d7fdb4d0215c9edcb1048491d8b361a22e88 /dev-ml
parentxfce-extra/xfce4-cpugraph-plugin: Bump to 1.2.4 (diff)
downloadgentoo-a9dfe8a9fc72a76428cc16daba1ab7a484a60e5c.tar.gz
gentoo-a9dfe8a9fc72a76428cc16daba1ab7a484a60e5c.tar.bz2
gentoo-a9dfe8a9fc72a76428cc16daba1ab7a484a60e5c.zip
dev-ml/lwt: build with ocaml-4.12
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/lwt/files/lwt-5.3.0-ocaml-4.12.patch24
-rw-r--r--dev-ml/lwt/lwt-5.3.0-r1.ebuild5
-rw-r--r--dev-ml/lwt/metadata.xml4
3 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/lwt/files/lwt-5.3.0-ocaml-4.12.patch b/dev-ml/lwt/files/lwt-5.3.0-ocaml-4.12.patch
new file mode 100644
index 000000000000..048e28d1d6bc
--- /dev/null
+++ b/dev-ml/lwt/files/lwt-5.3.0-ocaml-4.12.patch
@@ -0,0 +1,24 @@
+--- a/src/unix/lwt_unix.cppo.ml 2021-10-01 20:35:45.285987395 +0200
++++ b/src/unix/lwt_unix.cppo.ml 2021-10-01 20:36:19.570493202 +0200
+@@ -1819,6 +1819,9 @@
+ | SO_ACCEPTCONN
+ | TCP_NODELAY
+ | IPV6_ONLY
++#if OCAML_VERSION >= (4, 12, 0)
++ | SO_REUSEPORT
++#endif
+
+ type socket_int_option =
+ Unix.socket_int_option =
+--- a/src/unix/lwt_unix.cppo.mli 2021-10-01 20:33:57.558539065 +0200
++++ b/src/unix/lwt_unix.cppo.mli 2021-10-01 20:35:30.393202008 +0200
+@@ -1008,6 +1008,9 @@
+ | SO_ACCEPTCONN
+ | TCP_NODELAY
+ | IPV6_ONLY
++#if OCAML_VERSION >= (4, 12, 0)
++ | SO_REUSEPORT
++#endif
+
+ type socket_int_option =
+ Unix.socket_int_option =
diff --git a/dev-ml/lwt/lwt-5.3.0-r1.ebuild b/dev-ml/lwt/lwt-5.3.0-r1.ebuild
index b635eab67eb5..40958766de01 100644
--- a/dev-ml/lwt/lwt-5.3.0-r1.ebuild
+++ b/dev-ml/lwt/lwt-5.3.0-r1.ebuild
@@ -32,4 +32,9 @@ BDEPEND="
# backported from https://github.com/ocsigen/lwt/pull/807
PATCHES=(
"${FILESDIR}"/${PN}-5.3.0-ppxlib-0.18.0.patch
+ "${FILESDIR}"/${P}-ocaml-4.12.patch
)
+
+src_compile() {
+ dune build @install --profile release || die
+}
diff --git a/dev-ml/lwt/metadata.xml b/dev-ml/lwt/metadata.xml
index 18be4f6c21a9..52dc9a8f7464 100644
--- a/dev-ml/lwt/metadata.xml
+++ b/dev-ml/lwt/metadata.xml
@@ -1,6 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
<maintainer type="person">
<email>gienah@gentoo.org</email>
<name>Mark Wright</name>