summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-08 15:18:28 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-08 15:33:07 +0100
commitb5c4ee4b6849d3fed75d08d6c41b0403e9adcc12 (patch)
tree4777e9d0e202a285c952d3a6a2c3039cf90c0f6a /dev-ml
parentdev-ml/ocsigen-start: Bump to 1.0.0 (diff)
downloadgentoo-b5c4ee4b6849d3fed75d08d6c41b0403e9adcc12.tar.gz
gentoo-b5c4ee4b6849d3fed75d08d6c41b0403e9adcc12.tar.bz2
gentoo-b5c4ee4b6849d3fed75d08d6c41b0403e9adcc12.zip
dev-ml/ocsigen-toolkit: Bump to 1.0.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocsigen-toolkit/Manifest1
-rw-r--r--dev-ml/ocsigen-toolkit/ocsigen-toolkit-1.0.0.ebuild52
-rw-r--r--dev-ml/ocsigen-toolkit/ocsigen-toolkit-9999.ebuild4
3 files changed, 55 insertions, 2 deletions
diff --git a/dev-ml/ocsigen-toolkit/Manifest b/dev-ml/ocsigen-toolkit/Manifest
index 555f5a08c8c2..9c0717ba1b2c 100644
--- a/dev-ml/ocsigen-toolkit/Manifest
+++ b/dev-ml/ocsigen-toolkit/Manifest
@@ -1 +1,2 @@
DIST ocsigen-toolkit-0.99.tar.gz 68978 SHA256 fd42765a5f0d9297607160523bb99c4a6b2b6ef25b4c1464b6065bc98caea54b SHA512 a46577b4627a19a85c4f628dc47bfb81ba8da641dcf08e97df02f236e0a328086d8395aa165a9e82b42b3254c7d04f7d763c12cd7495f427a6d681544ad7963b WHIRLPOOL a496e41ec1974c0c841f4e154182a407326884067ffd389a83824b5957fe1f320643856acf422239e67d4a7a5dace1ab1f703c869b87feb6f8c16855cc78ce36
+DIST ocsigen-toolkit-1.0.0.tar.gz 69175 SHA256 427e5e4d11215862dcb012b769aea9e6c63b8799d9bde5076893eea3b575a472 SHA512 4776dcceef822ac63fd6d57ce05e870f726c1e1d137bab239b8558acb4ef55f97b847825f621414334b01d30c066ea986d2b8180b80a09719b5b76cb3bb69a20 WHIRLPOOL 4718049847f3a2e7e219a21ec9f8082d467808791010dac92426c8ec7e70c03783f8de5d2bfba600c27c89c46efac0c07502eb04a7de685fae09030d0000526a
diff --git a/dev-ml/ocsigen-toolkit/ocsigen-toolkit-1.0.0.ebuild b/dev-ml/ocsigen-toolkit/ocsigen-toolkit-1.0.0.ebuild
new file mode 100644
index 000000000000..79b2c5de5529
--- /dev/null
+++ b/dev-ml/ocsigen-toolkit/ocsigen-toolkit-1.0.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="User interface widgets for Ocsigen applications"
+HOMEPAGE="https://github.com/ocsigen/ocsigen-toolkit"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt debug"
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/ocsigen/ocsigen-toolkit"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ocsigen/ocsigen-toolkit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt?]
+ >dev-ml/js_of_ocaml-2.7:=
+ >=dev-ml/eliom-5.1:=[ppx]
+ dev-ml/ppx_deriving:=
+ dev-ml/calendar:=
+ dev-ml/lwt:="
+DEPEND="${RDEPEND}
+ dev-ml/opam"
+
+src_compile() {
+ emake \
+ DEBUG="$(usex debug yes no)" \
+ NATIVE="$(usex ocamlopt yes no)" \
+ all
+}
+
+src_install() {
+ findlib_src_preinst
+ OCAMLPATH="${OCAMLFIND_DESTDIR}" emake install
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc README.md
+}
diff --git a/dev-ml/ocsigen-toolkit/ocsigen-toolkit-9999.ebuild b/dev-ml/ocsigen-toolkit/ocsigen-toolkit-9999.ebuild
index 08cdc51e1ae1..79b2c5de5529 100644
--- a/dev-ml/ocsigen-toolkit/ocsigen-toolkit-9999.ebuild
+++ b/dev-ml/ocsigen-toolkit/ocsigen-toolkit-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -20,7 +20,7 @@ if [ "${PV#9999}" != "${PV}" ] ; then
EGIT_REPO_URI="https://github.com/ocsigen/ocsigen-toolkit"
KEYWORDS=""
else
- SRC_URI="https://github.com/ocsigen/ocsigen-toolkit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/ocsigen/ocsigen-toolkit/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi