summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-09-23 02:00:43 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-09-23 02:09:40 +0200
commitb6e876fec2a0275b1f94ddc6fae0b37702116f49 (patch)
tree14764697c77a0e053680a7e70103ca79f6346e45 /dev-ml
parentvirtual/rust: keyword 1.63.0 for ~mips (diff)
downloadgentoo-b6e876fec2a0275b1f94ddc6fae0b37702116f49.tar.gz
gentoo-b6e876fec2a0275b1f94ddc6fae0b37702116f49.tar.bz2
gentoo-b6e876fec2a0275b1f94ddc6fae0b37702116f49.zip
dev-ml/yojson: bump to 2.0.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/yojson/Manifest1
-rw-r--r--dev-ml/yojson/yojson-2.0.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/yojson/Manifest b/dev-ml/yojson/Manifest
index 411b2a92266e..de9acdd856c1 100644
--- a/dev-ml/yojson/Manifest
+++ b/dev-ml/yojson/Manifest
@@ -1,2 +1,3 @@
DIST yojson-1.7.0.tar.gz 29704 BLAKE2B edbd7f66d69a85880fc8ee9bb25a993744a310887024f7af63665ba8f5067f1b9383ec4d6dd5f4ca3376d698665a8f605c078f7597ddd4e71857c1a20143c2e5 SHA512 25eedb64e4bf7c7e8d5a5a115812cd502540afbdeb7c947da3a14e5968aa0a7db8ab402425662571d8935b9cd6a19796ce81dd80a65dc614f156626c60e7036e
DIST yojson-2.0.0.tar.gz 44446 BLAKE2B 3b221a016ba418cc6a413921f0d7f2bc239b9a84953bbe9bec2601b159442f3e8bebdf48447367660fec3b3929ea0c08453778e491ce17f9044f505e49d587a6 SHA512 9196e117bb712b970351d12a8d7eae345eef2c92e70e627b58bb95ee49cd58e8a51e6eb5746e2468c15133d53a448ccd229a0568227de0cc8d2eed8b1985609b
+DIST yojson-2.0.2.tar.gz 46731 BLAKE2B adca246c055efe04b63e694b7735fc81a714ae3b3ab164152797cc1eff1e483976b80ff31d0ac90f9d4ac234304ec805abb118bb231d0479bc738ddeb56a236c SHA512 61e8084d66d62d05a7802ee82a414807a76959ce6e0b14fd01f1c9c71ea69976d8a2cf3d5718e4059da4161786136a08624cd8470693ef2893b862efa7d6ffd2
diff --git a/dev-ml/yojson/yojson-2.0.2.ebuild b/dev-ml/yojson/yojson-2.0.2.ebuild
new file mode 100644
index 000000000000..23350f1a6c06
--- /dev/null
+++ b/dev-ml/yojson/yojson-2.0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="JSON parsing and pretty-printing library for OCaml"
+HOMEPAGE="https://github.com/ocaml-community/yojson"
+SRC_URI="https://github.com/ocaml-community/yojson/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="examples +ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02.3:=[ocamlopt?]
+ >=dev-ml/seq-0.2.2:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-ml/cppo-1.6.1
+ test? ( dev-ml/alcotest )"
+
+src_prepare() {
+ default
+ # let's not build this
+ rm bench/dune yojson-bench.opam || die
+}
+
+src_install() {
+ dune_src_install
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}