summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2017-01-14 20:55:23 +0300
committerMikle Kolyada <zlogene@gentoo.org>2017-01-14 20:57:06 +0300
commitc181d7e1d18893b63a3f4c5655b581c2fe5658bb (patch)
tree3da99c0ea7038a8893f75a9aa42e572cdcd43e2d /dev-ml
parentdev-scheme/schoca: rm invalid dep,eapi bump (diff)
downloadgentoo-c181d7e1d18893b63a3f4c5655b581c2fe5658bb.tar.gz
gentoo-c181d7e1d18893b63a3f4c5655b581c2fe5658bb.tar.bz2
gentoo-c181d7e1d18893b63a3f4c5655b581c2fe5658bb.zip
dev-ml/lablgtk: ia64/sparc stable
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/lablgtk/lablgtk-2.18.3-r1.ebuild4
-rw-r--r--dev-ml/lablgtk/lablgtk-2.18.3.ebuild83
2 files changed, 2 insertions, 85 deletions
diff --git a/dev-ml/lablgtk/lablgtk-2.18.3-r1.ebuild b/dev-ml/lablgtk/lablgtk-2.18.3-r1.ebuild
index 53294ba14701..a530b4ecbc10 100644
--- a/dev-ml/lablgtk/lablgtk-2.18.3-r1.ebuild
+++ b/dev-ml/lablgtk/lablgtk-2.18.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -28,7 +28,7 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
SLOT="2/${PV}"
-KEYWORDS="alpha amd64 ~ia64 ppc ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
src_configure() {
econf $(use_enable debug) \
diff --git a/dev-ml/lablgtk/lablgtk-2.18.3.ebuild b/dev-ml/lablgtk/lablgtk-2.18.3.ebuild
deleted file mode 100644
index 46dbd4b863e2..000000000000
--- a/dev-ml/lablgtk/lablgtk-2.18.3.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit multilib findlib
-
-IUSE="debug examples glade gnomecanvas sourceview +ocamlopt opengl spell svg"
-
-DESCRIPTION="Objective CAML interface for Gtk+2"
-HOMEPAGE="http://lablgtk.forge.ocamlcore.org/"
-SRC_URI="https://forge.ocamlcore.org/frs/download.php/1479/${P}.tar.gz"
-LICENSE="LGPL-2.1-with-linking-exception examples? ( lablgtk-examples )"
-
-RDEPEND=">=x11-libs/gtk+-2.10:2
- >=dev-lang/ocaml-3.10:=[ocamlopt?]
- svg? ( >=gnome-base/librsvg-2.2:2 )
- glade? ( >=gnome-base/libglade-2.0.1 )
- gnomecanvas? ( >=gnome-base/libgnomecanvas-2.2 )
- opengl? ( >=dev-ml/lablgl-0.98:=
- >=x11-libs/gtkglarea-1.9:2 )
- spell? ( app-text/gtkspell:2 )
- sourceview? ( x11-libs/gtksourceview:2.0 )
- <dev-lang/ocaml-4.02.0
- "
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-SLOT="2/${PV}"
-KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-
-src_configure() {
- econf $(use_enable debug) \
- $(use_with svg rsvg) \
- $(use_with glade) \
- --without-gnomeui \
- --without-panel \
- $(use_with opengl gl) \
- $(use_with spell gtkspell) \
- --without-gtksourceview \
- $(use_with sourceview gtksourceview2) \
- $(use_with gnomecanvas)
-}
-
-src_compile() {
- emake -j1 all
- if use ocamlopt; then
- emake -j1 opt
- fi
-}
-
-install_examples() {
- insinto /usr/share/doc/${P}/examples
- doins examples/*.ml examples/*.rgb examples/*.png examples/*.xpm
-
- # Install examples for optional components
- use gnomecanvas && insinto /usr/share/doc/${PF}/examples/canvas && doins examples/canvas/*.ml examples/canvas/*.png
- use svg && insinto /usr/share/doc/${PF}/examples/rsvg && doins examples/rsvg/*.ml examples/rsvg/*.svg
- use glade && insinto /usr/share/doc/${PF}/examples/glade && doins examples/glade/*.ml examples/glade/*.glade*
- use sourceview && insinto /usr/share/doc/${PF}/examples/sourceview && doins examples/sourceview/*.ml examples/sourceview/*.lang
- use opengl && insinto /usr/share/doc/${PF}/examples/GL && doins examples/GL/*.ml
-
- docompress -x /usr/share/doc/${PF}/examples
-}
-
-src_install () {
- findlib_src_preinst
- export OCAMLPATH="${OCAMLFIND_DESTDIR}"
- emake install DESTDIR="${D}"
-
- rm -f "${ED}/usr/$(get_libdir)/ocaml/ld.conf"
-
- dodoc CHANGES README CHANGES.API
- use examples && install_examples
-}
-
-pkg_postinst () {
- if use examples; then
- elog "To run the examples you can use the lablgtk2 toplevel."
- elog "e.g: lablgtk2 /usr/share/doc/${PF}/examples/testgtk.ml"
- fi
-}