summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-26 23:45:54 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-27 09:34:01 +0100
commitc86c4fc678bf5bc2c227e64b6d4c236ceef1b883 (patch)
tree485ffe4abf4bd8ee6759778319694ab4f5aa6781 /dev-ml
parentdev-php/pecl-mailparse: amd64 stable wrt bug #610940 (diff)
downloadgentoo-c86c4fc678bf5bc2c227e64b6d4c236ceef1b883.tar.gz
gentoo-c86c4fc678bf5bc2c227e64b6d4c236ceef1b883.tar.bz2
gentoo-c86c4fc678bf5bc2c227e64b6d4c236ceef1b883.zip
dev-ml/parmap: Bump to 1.0 rc8
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/parmap/Manifest1
-rw-r--r--dev-ml/parmap/parmap-1.0_rc8.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-ml/parmap/Manifest b/dev-ml/parmap/Manifest
index 172297bb1d87..bed3beb463a7 100644
--- a/dev-ml/parmap/Manifest
+++ b/dev-ml/parmap/Manifest
@@ -1 +1,2 @@
DIST parmap-1.0_rc7-ocaml-4.03.tar.gz 98262 SHA256 78f3baa7f9b9c7b5e2a3571624b844fce2b0b9f8744ebf5309ad880e74940fbb SHA512 c8b7678fede76d35b299ef0548ef3819f9ec056cde4d5498e11f2400b96149b17ce58c35d197d10dba5fd4a702b94fe78090e1f330791b0f470891f0bbf7a544 WHIRLPOOL 1e21a0676458222938afab3feec4f23048537870b10fa62a4c213368642eed642d3c4cf0e167d3267a7d0237be7ea0e1c13e8c164a8020a5f32acb7b1f4e568b
+DIST parmap-1.0_rc8.tar.gz 98699 SHA256 288fe4e72c10e9866cd8173bedf052d62421646a2a8aaffe96b70239695cf7a4 SHA512 96bbe49f06dc3611577e87d9e6f5ca32e10271d6a14a0970bd4548fcaf268f833b3143258e14328237a60578e2355687e4bff031a021903f3e2280ef1713cc65 WHIRLPOOL c80fbf635429050fc3d1494cb190107f9bf220435902b943e820d1e3340ed9e3b28cf4cf7d310ee9a4b6014fb8cdd9de4eb0415ef70ef4b83770f7969d7a27e5
diff --git a/dev-ml/parmap/parmap-1.0_rc8.ebuild b/dev-ml/parmap/parmap-1.0_rc8.ebuild
new file mode 100644
index 000000000000..0a047be43a2a
--- /dev/null
+++ b/dev-ml/parmap/parmap-1.0_rc8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib
+
+MY_PV="${PV/_/-}"
+DESCRIPTION="Library allowing to exploit multicore architectures for OCaml programs with minimal modifications"
+HOMEPAGE="http://www.dicosmo.org/code/parmap/"
+SRC_URI="https://github.com/rdicosmo/parmap/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-4.03:=[ocamlopt?]"
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ dev-ml/ocamlbuild
+ dev-ml/ocaml-autoconf"
+S="${WORKDIR}/${PN}-${MY_PV/+/-}"
+
+src_test() {
+ mkdir "${WORKDIR}/tmpinstall" || die
+ emake \
+ OCAMLLIBDIR="ocaml" \
+ DESTDIR="${WORKDIR}/tmpinstall" \
+ install
+ export OCAMLPATH="${WORKDIR}/tmpinstall/ocaml"
+ emake tests
+ cd _build/tests || die
+ for i in $(find . -type f -executable) ; do
+ ${i} || die
+ done
+}
+
+src_install() {
+ emake \
+ OCAMLLIBDIR="$(get_libdir)/ocaml" \
+ MANDIR="${ED}/usr/share/man/man3o" \
+ DESTDIR="${ED}/usr" \
+ install
+ dodoc AUTHORS Changelog README
+}