summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 13:17:16 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-01 14:24:43 +0200
commitc932babce8c9c3a4c7e10ec57c45c814b01a056c (patch)
treedc0c0f36fdb445379cd1fdc076750831b165a5c8 /dev-ml
parentdev-ml/pomap: Bump to 3.0.7 (diff)
downloadgentoo-c932babce8c9c3a4c7e10ec57c45c814b01a056c.tar.gz
gentoo-c932babce8c9c3a4c7e10ec57c45c814b01a056c.tar.bz2
gentoo-c932babce8c9c3a4c7e10ec57c45c814b01a056c.zip
dev-ml/reason-parser: Initial import. Ebuild by me.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/reason-parser/Manifest1
-rw-r--r--dev-ml/reason-parser/metadata.xml8
-rw-r--r--dev-ml/reason-parser/reason-parser-1.13.3.ebuild50
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-ml/reason-parser/Manifest b/dev-ml/reason-parser/Manifest
new file mode 100644
index 000000000000..8a45cb0d2a84
--- /dev/null
+++ b/dev-ml/reason-parser/Manifest
@@ -0,0 +1 @@
+DIST reason-parser-1.13.3.tar.gz 10253108 SHA256 b92840f8238dd6266c5678da3e4dc832776bcc98990ac47773020e34dce708a6 SHA512 82398fbbf72bcadfc868e5f33e8666ef80ef610f8313d08bc16593944569b7a16693fcc6397a117518bf8e32f71083f0ac4a416112f97cd220715f4293136b84 WHIRLPOOL a82dd8e28a012ed0716fba6bc79eee849110bfb42cd8221eb15847cadae90d62d909e635f3da465c6220382d6eee62f2f69a739d96d3d6a5baddc58623cd059e
diff --git a/dev-ml/reason-parser/metadata.xml b/dev-ml/reason-parser/metadata.xml
new file mode 100644
index 000000000000..ffac4d7ebc01
--- /dev/null
+++ b/dev-ml/reason-parser/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/reason-parser/reason-parser-1.13.3.ebuild b/dev-ml/reason-parser/reason-parser-1.13.3.ebuild
new file mode 100644
index 000000000000..e9a7ae9ee3bc
--- /dev/null
+++ b/dev-ml/reason-parser/reason-parser-1.13.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="Meta Language Toolchain"
+HOMEPAGE="https://github.com/facebook/reason"
+SRC_URI="https://github.com/facebook/reason/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-lang/ocaml:=[ocamlopt?]
+ dev-ml/menhir:=
+ dev-ml/merlin-extend:=
+ dev-ml/result:=
+ dev-ml/topkg:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/ppx_tools_versioned:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/ocamlbuild
+ dev-ml/opam
+"
+
+S="${WORKDIR}/reason-${PV}/${PN}"
+
+src_compile() {
+ emake compile_error
+ ocamlbuild -package topkg pkg/build.native || die
+ ./build.native build \
+ --native "$(usex ocamlopt true false)" \
+ --native-dynlink "$(usex ocamlopt true false)" \
+ || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ --mandir="${ED}/usr/share/man" \
+ ${PN}.install || die
+}