summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-28 03:03:09 +0100
committerSam James <sam@gentoo.org>2021-07-28 03:03:09 +0100
commitcc72ccca5d65ac57e8e0765a4f03f0666bb10697 (patch)
treea27dc8854e6c6b8f408832d416c647c83d8115e2 /dev-ml
parentdev-ml/bos: adopt for ml@ (diff)
downloadgentoo-cc72ccca5d65ac57e8e0765a4f03f0666bb10697.tar.gz
gentoo-cc72ccca5d65ac57e8e0765a4f03f0666bb10697.tar.bz2
gentoo-cc72ccca5d65ac57e8e0765a4f03f0666bb10697.zip
dev-ml/bos: add 0.2.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/bos/Manifest1
-rw-r--r--dev-ml/bos/bos-0.2.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-ml/bos/Manifest b/dev-ml/bos/Manifest
index 1605b9165f82..455b1d3ba519 100644
--- a/dev-ml/bos/Manifest
+++ b/dev-ml/bos/Manifest
@@ -1 +1,2 @@
DIST bos-0.1.6.tbz 39822 BLAKE2B 0e10eb14fb5d429b81c67659c936e8b700c4cd417d1f5be000c8bdb0304de8ad9130e597f6e2e7771380c29c148f4339817bacc458e72a8efa894be3b85965bf SHA512 f1f10a97a32da936a7d5a0c70632e723723ee523c79f9dfd23bc42c039a194e8d69658483e6e856c7911332b799a92bf8cabfe96cc387522d7450b8f3f8f8343
+DIST bos-0.2.0.tbz 41008 BLAKE2B badc344e561ba9335a4ded0c8100da91fe2bc882698c94daa42d9db2f1e2c8c627b81eebb5a7067778c332384504391ea402f7363ec552e8517cb048c8e384fe SHA512 f9120f8108c6da5647c9fbcc78736a5f87bf5627fad01035fdab1af6322c93e75df670d7d2910fe474c92c48ffffcf15955a84e698cfc7bfb7c1ac4fe27d472f
diff --git a/dev-ml/bos/bos-0.2.0.ebuild b/dev-ml/bos/bos-0.2.0.ebuild
new file mode 100644
index 000000000000..48d5b1537079
--- /dev/null
+++ b/dev-ml/bos/bos-0.2.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Basic OS interaction for OCaml"
+HOMEPAGE="https://erratique.ch/software/bos https://github.com/dbuenzli/bos"
+SRC_URI="https://erratique.ch/software/bos/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-lang/ocaml:=
+ dev-ml/rresult:=
+ dev-ml/astring:=
+ dev-ml/fpath:=
+ dev-ml/fmt:=
+ dev-ml/logs:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ dev-ml/ocamlbuild
+ dev-ml/topkg
+ test? ( dev-ml/mtime )
+"
+
+src_compile() {
+ ocaml pkg/pkg.ml build --tests $(usex test true false) || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}