summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-15 10:12:31 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-15 10:49:42 +0200
commitd886061d8cac61620d2563376bf6bc2dc35ec957 (patch)
treedbc4bc0b7f0636add9e3e77b9cfa982bf0eb01b0 /dev-ml
parentwww-client/firefox: amd64 stable wrt bug #621722 (diff)
downloadgentoo-d886061d8cac61620d2563376bf6bc2dc35ec957.tar.gz
gentoo-d886061d8cac61620d2563376bf6bc2dc35ec957.tar.bz2
gentoo-d886061d8cac61620d2563376bf6bc2dc35ec957.zip
dev-ml/markup: bump to 0.7.5
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/markup/Manifest1
-rw-r--r--dev-ml/markup/markup-0.7.5.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/markup/Manifest b/dev-ml/markup/Manifest
index 914d412721f2..17b4d645cfb0 100644
--- a/dev-ml/markup/Manifest
+++ b/dev-ml/markup/Manifest
@@ -1 +1,2 @@
DIST markup-0.7.4.tar.gz 278855 SHA256 2d006e1cec3b46ef403051d88ba786d95c74b162f2e6d48e2d81ee17f2be357b SHA512 82f20274f6f83e994133403be900f8536c073d6dc8a7c3d02ac8bc4a07ec33ec8c8afe36d4ce0b79433d6ec346c85d1f5ab7b62292e5b092f4911693bb6876ef WHIRLPOOL 7ac847c98fa1afb3a9be5626dbccbd9ddeae15b68c74f7fa9d846e715839d1530cd3bf1abe68d33113ba0dee44698f9efd58bea562d8cd4bbca527b3c97c718b
+DIST markup-0.7.5.tar.gz 278654 SHA256 1987eb677512c277830f3ae0eb9cada6fa07b5686daeb5d39a389a52d55a450f SHA512 19350df7a3a619c479fa030b8772009bc32f3e9830494f5707e05f85b9ee9ff0ddf382d292c7a11bbd3b63c8c108e6a84b2d01f5e983f49d7cdf63ee3c4545c8 WHIRLPOOL 70b017210f4f194ee00e5e4b9c4efc232f6a4c93196d464986c0b09477e958d291a2991a42912c57ea25c6310ea6ce75aa8ac5941e3c7a84de7690bb62f145ff
diff --git a/dev-ml/markup/markup-0.7.5.ebuild b/dev-ml/markup/markup-0.7.5.ebuild
new file mode 100644
index 000000000000..6936fe4a8367
--- /dev/null
+++ b/dev-ml/markup/markup-0.7.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="Error-recovering streaming HTML5 and XML parsers"
+HOMEPAGE="https://github.com/aantron/markup.ml"
+SRC_URI="https://github.com/aantron/markup.ml/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}p1"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+ dev-lang/ocaml:=[ocamlopt]
+ dev-ml/lwt:=[ocamlopt]
+ >=dev-ml/uutf-1.0:=[ocamlopt]
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ test? ( dev-ml/ounit )
+ dev-ml/ocamlbuild"
+S="${WORKDIR}/${PN}.ml-${PV}"
+
+src_compile() {
+ emake
+ use doc && emake docs
+}
+
+src_install() {
+ findlib_src_preinst
+ emake ocamlfind-install
+ dodoc README.md
+ use doc && dohtml doc/html/*
+}