summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-08-26 15:51:29 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-08-26 15:51:39 +0200
commitd88d826f12f315baffa8d3f09256f06f08347afb (patch)
tree75a9443a5e2927604767f5f71572ece006a088fe /dev-ml
parentprofiles: Remove outdated entries from package.use.force (diff)
downloadgentoo-d88d826f12f315baffa8d3f09256f06f08347afb.tar.gz
gentoo-d88d826f12f315baffa8d3f09256f06f08347afb.tar.bz2
gentoo-d88d826f12f315baffa8d3f09256f06f08347afb.zip
dev-ml/pcre-ocaml: bump to 7.1.6.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/pcre-ocaml/Manifest1
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-7.1.6.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/pcre-ocaml/Manifest b/dev-ml/pcre-ocaml/Manifest
index f95ef22c6049..df68ecf330f6 100644
--- a/dev-ml/pcre-ocaml/Manifest
+++ b/dev-ml/pcre-ocaml/Manifest
@@ -3,3 +3,4 @@ DIST pcre-ocaml-7.0.2.tar.gz 81910 SHA256 052a2fdd8da597724ac8ca474fdd40772b4618
DIST pcre-ocaml-7.0.4.tar.gz 84956 SHA256 fc56b0e0f7ab5d159af77d1a51f67d0dd0b86ef30eccc0e9cbef4f79d4a75840 SHA512 2b00a784bcda8c476014875c87cb12b2dc111f0c003c4fa3aedc4963ed1a75fc7cde22b20bdf071e2637bdfe7bf0fe094e5073a141644acaefdecddca6b6af72 WHIRLPOOL c3352fe803924649867b8f63da137ab81a15b4c12f3855610097513bf093df43d6d9a1c7d0992ff0a1a4ccca873b538b28285811218d6a833faf6a994026bb69
DIST pcre-ocaml-7.1.3.tar.gz 88056 SHA256 43f8e20a55d4c079f202234781f9eaee48e938eea55fa68aa6a7cdcb3fce7896 SHA512 6cc51205b04fa65cb03b9b3064deabd2d9995e8ae88281519df56d27025158f9c1ae64a9e194643681d7481dc56aa0edd65b13a4c04ad64b83e1c201e5137484 WHIRLPOOL 897643040952a9f3007e67bdc1046b37a3dd4a8fb9bd83074c588f21ab09dc7a42bb1154b6b1e9d64a4dfd72ec85d0bf7159d95021c437feb38c49b7d394c316
DIST pcre-ocaml-7.1.5.tar.gz 88068 SHA256 6495ecf25ed6a69fd14fda472f9fac9853dde2aee9944f6b6c0111d458c1039b SHA512 5b02c62af248834dfbcf4e6ff052ec70e7c43ef8a82f7a4f0e900060f37f4fcdebf4234c5c3afdfb780b12d4a562855d8a904c87f2d20f671831f62313cb20cc WHIRLPOOL 9a1dd4552c45178e7f2c9357dd5349c030f7416fa774a116f53a8a7e3eb46d594314ee5c1c8c7de5b7d50dc2114cf368bb1cb8c4791fba3b9606a62d1867b90b
+DIST pcre-ocaml-7.1.6.tar.gz 88104 SHA256 7f88d1fb44a394026f20c692170d36f7331cbeea20ca95b841334b8c188efbef SHA512 604bf27324eab3548c8320bee91cd8c8d0c6459aa7c02b576149b6a2beb43ddd9733e7e344c20c100241cabc84be61ef8c4a5515cdd994a7c3105dd3da74782d WHIRLPOOL 25ba4642e4d10300d849993dd5cb18cb9c8216ba17b07756bca866b46460b8cc7399c91cc6390e44250765d40aa81a5ff3c0372bb3ead614c27c9b4a4f3da3d2
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-7.1.6.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-7.1.6.ebuild
new file mode 100644
index 000000000000..4eea14f760aa
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-7.1.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://mmottl.github.io/pcre-ocaml/ https://github.com/mmottl/pcre-ocaml"
+SRC_URI="https://github.com/mmottl/pcre-ocaml/releases/download/v${PV}/${P}.tar.gz"
+LICENSE="LGPL-2.1-with-linking-exception"
+IUSE="examples"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND=">=dev-libs/libpcre-4.5
+ >=dev-lang/ocaml-4:="
+DEPEND="${RDEPEND}"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}