summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-22 11:06:17 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-22 11:06:26 +0100
commitec8a5478b8b65138b052afdd20a52254e0db707b (patch)
tree464b14d8c341306f6ba580ae190fc769ba3b54f2 /dev-ml
parentdev-cpp/eigen: Drop -g2 from build flags (diff)
downloadgentoo-ec8a5478b8b65138b052afdd20a52254e0db707b.tar.gz
gentoo-ec8a5478b8b65138b052afdd20a52254e0db707b.tar.bz2
gentoo-ec8a5478b8b65138b052afdd20a52254e0db707b.zip
dev-ml/pgocaml: bump to 2.3
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/pgocaml/Manifest1
-rw-r--r--dev-ml/pgocaml/metadata.xml3
-rw-r--r--dev-ml/pgocaml/pgocaml-2.3.ebuild33
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/pgocaml/Manifest b/dev-ml/pgocaml/Manifest
index 80c64cdafee7..97c8a308c5fa 100644
--- a/dev-ml/pgocaml/Manifest
+++ b/dev-ml/pgocaml/Manifest
@@ -1 +1,2 @@
DIST pgocaml-2.2.tgz 88613 SHA256 3027ca823f9f3db24475bd36e5628ee259605d72048d889be3b7e32c3e850d74 SHA512 1358e377d46aeb8fa00f44ba47dcc61097919584accc96264ae751cd2d6b8380dd2135109d5f6bf7963f3b448ee59046210c6335a3750deed4ad0ce5fc0a9d8d WHIRLPOOL 53da87c02670d493ff0dd12c467d69bac630aa9fe5141be074f328722c305611ad951d14fafe941961dd40d4b6af012ef4e3a305bb6df96734c13f01473c4520
+DIST pgocaml-2.3.tgz 90383 SHA256 ef8ec253a752eb31e535d845440185b95c4de31db8c5c955e79638b669af9ea2 SHA512 f42ca8ccf31f9e03cfa9f81a9cd19c2a6010c33f5a578e76924683fd10ab4acf2727b09b71c5a8f200bc39765a5d876a289976fea367b49ae54335c007fd3ff7 WHIRLPOOL 48a8adb944db6bce29f818f287d47b35d0b776f3eb5bb68e0e835a4ac451405d46bbd3fcdc14c1ee9542f9b0afecd5e7b98a2f74d32fdbb7efe61c232414a0f7
diff --git a/dev-ml/pgocaml/metadata.xml b/dev-ml/pgocaml/metadata.xml
index 76bbff93b8c7..5916b25a8911 100644
--- a/dev-ml/pgocaml/metadata.xml
+++ b/dev-ml/pgocaml/metadata.xml
@@ -5,4 +5,7 @@
<email>ml@gentoo.org</email>
<name>Gentoo ML Project</name>
</maintainer>
+ <use>
+ <flag name="camlp4">Enable PG'Ocaml syntax extension.</flag>
+ </use>
</pkgmetadata>
diff --git a/dev-ml/pgocaml/pgocaml-2.3.ebuild b/dev-ml/pgocaml/pgocaml-2.3.ebuild
new file mode 100644
index 000000000000..c9e22b4b42ac
--- /dev/null
+++ b/dev-ml/pgocaml/pgocaml-2.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="PG'OCaml is a set of OCaml bindings for the PostgreSQL database"
+HOMEPAGE="http://pgocaml.forge.ocamlcore.org/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1597/${P}.tgz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="camlp4 doc"
+
+DEPEND="dev-ml/calendar:=
+ dev-ml/csv:=
+ dev-ml/pcre-ocaml:=
+ camlp4? ( dev-ml/camlp4:= )"
+RDEPEND="${DEPEND}"
+
+DOCS=( "README.md" "CHANGELOG.txt"
+ "doc/BUGS.txt" "doc/CONTRIBUTORS.txt"
+ "doc/HOW_IT_WORKS.txt" "doc/PROFILING.txt"
+ )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable camlp4 p4)" oasis_src_configure
+}