summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-01-16 06:47:03 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-01-16 13:20:45 +0100
commitf0034d84232cfa568517860884193811ea33ed46 (patch)
tree214735c3e3ef6e4c74a8d3fb73e7213140406dba /dev-ml
parentdev-ml/uunf: bump to 15.0.0 (diff)
downloadgentoo-f0034d84232cfa568517860884193811ea33ed46.tar.gz
gentoo-f0034d84232cfa568517860884193811ea33ed46.tar.bz2
gentoo-f0034d84232cfa568517860884193811ea33ed46.zip
dev-ml/uucp: bump to 15.0.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/uucp/Manifest1
-rw-r--r--dev-ml/uucp/uucp-15.0.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/uucp/Manifest b/dev-ml/uucp/Manifest
index 783aec0484d8..a7834ad61604 100644
--- a/dev-ml/uucp/Manifest
+++ b/dev-ml/uucp/Manifest
@@ -1,2 +1,3 @@
DIST uucp-13.0.0.tbz 466488 BLAKE2B 90b62446ed069f95b0ca8bbad8273b215f0a66f6a3d19639d60a73f440268e9274d4e98e7ac8a534bbb6a34ab485e989432894f22f2f5c1303ca49f828efe859 SHA512 24d0fc75ba337115fd6445d3c3dfa60fe5f6920b227cd8360cd60ad51b652ccc2129a47f195f7559d99635367e64855343dc03de1109987f296a280e0fefff4d
DIST uucp-14.0.0.tbz 476162 BLAKE2B 1c75b7bf98858bc60dee12bebfa99556afd6b344b65b12a4eafcbd39c57e2359f1a47aa0f28c5450f078db95d78ab545eecf84d0d5dbadb2bf1705c17e7179a4 SHA512 2d0224aed5d5accbb121624898f08598e8c74a2415942f159a54221c0cdac62ed64fc70a039c833e50110cefce77754ada9ac2d58f79a6fc9331135326fe6899
+DIST uucp-15.0.0.tbz 481932 BLAKE2B f8f23b8233e65b77dbea5defb968d253a022556b11f0276094fcdebe010fe5de99c36f581fee6aa3e54afadff62345fa5a3d6951ba0baba394f4ddae4175ba1c SHA512 ee4acff5666961766321e85e287fb9d5b8d50533319f22bf6f4eceb943242df2d0e0f4e775c4a140f68ca142837938eaa5926e22362215a3365ffe7f8768923b
diff --git a/dev-ml/uucp/uucp-15.0.0.ebuild b/dev-ml/uucp/uucp-15.0.0.ebuild
new file mode 100644
index 000000000000..0a4cae3ed550
--- /dev/null
+++ b/dev-ml/uucp/uucp-15.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam
+
+DESCRIPTION="Unicode character properties for OCaml"
+HOMEPAGE="https://erratique.ch/software/uucp https://github.com/dbuenzli/uucp"
+SRC_URI="https://erratique.ch/software/uucp/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-ml/topkg
+ dev-ml/findlib"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-ml/ocamlbuild"
+OPAM_FILE=opam
+
+src_compile() {
+ ocaml pkg/pkg.ml build \
+ --with-uutf true \
+ --with-uunf false \
+ --with-cmdliner true \
+ || die
+}