summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-22 04:13:52 +0000
committerSam James <sam@gentoo.org>2021-04-04 06:09:18 +0000
commitf3ee72e4db74ecf8657231b36cf57b46a6768d9f (patch)
treebcc80b1d7e4bd99fc7ed525a0c8a2e92d4646c8f /dev-ml
parentdev-ml/ocaml-dispatch: treeclean (diff)
downloadgentoo-f3ee72e4db74ecf8657231b36cf57b46a6768d9f.tar.gz
gentoo-f3ee72e4db74ecf8657231b36cf57b46a6768d9f.tar.bz2
gentoo-f3ee72e4db74ecf8657231b36cf57b46a6768d9f.zip
dev-ml/ocaml-cstruct: treeclean
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-cstruct/Manifest1
-rw-r--r--dev-ml/ocaml-cstruct/metadata.xml16
-rw-r--r--dev-ml/ocaml-cstruct/ocaml-cstruct-3.1.1.ebuild65
3 files changed, 0 insertions, 82 deletions
diff --git a/dev-ml/ocaml-cstruct/Manifest b/dev-ml/ocaml-cstruct/Manifest
deleted file mode 100644
index 68f49f48f9e4..000000000000
--- a/dev-ml/ocaml-cstruct/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST ocaml-cstruct-3.1.1.tar.gz 208725 BLAKE2B 2818c5695c4ab3d102cfa08a288e80e80d7fa4372a5d97aac831429f0681e21cb6b03baac245c7c1171a8efa23b8d6bca661ee74db0efe8c2649727d9be56505 SHA512 22ec8fe027dbebee537ff950c2aa9a494d0c4c000d8c4df848eae157b1c9502b73c208bb92c21fa4c13ba0291b7750de31e4c96b3a0571397402f841c3e01c21
diff --git a/dev-ml/ocaml-cstruct/metadata.xml b/dev-ml/ocaml-cstruct/metadata.xml
deleted file mode 100644
index ff9cc5cb9108..000000000000
--- a/dev-ml/ocaml-cstruct/metadata.xml
+++ /dev/null
@@ -1,16 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>ml@gentoo.org</email>
- <name>ML</name>
- </maintainer>
- <use>
- <flag name="async">Support for asynchronous execution</flag>
- <flag name="lwt">Enable threads via lwt</flag>
- <flag name="ppx">Enable the ppx syntax extension</flag>
- </use>
- <upstream>
- <remote-id type="github">mirage/ocaml-cstruct</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-ml/ocaml-cstruct/ocaml-cstruct-3.1.1.ebuild b/dev-ml/ocaml-cstruct/ocaml-cstruct-3.1.1.ebuild
deleted file mode 100644
index f766d6e0c4f8..000000000000
--- a/dev-ml/ocaml-cstruct/ocaml-cstruct-3.1.1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit findlib opam
-
-DESCRIPTION="Map OCaml arrays onto C-like structs"
-HOMEPAGE="https://github.com/mirage/ocaml-cstruct https://mirage.io"
-SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="async +lwt +ppx test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- async? (
- dev-ml/async_kernel:=
- dev-ml/async_unix:=
- dev-ml/core_kernel:=
- )
- lwt? ( dev-ml/lwt:= )
- ppx? (
- dev-ml/ppx_tools:=
- dev-ml/ocaml-migrate-parsetree:=
- >=dev-ml/ppx_tools_versioned-5.0.1:=
- )
- dev-ml/ocplib-endian:=
- dev-ml/sexplib:=
- dev-ml/type-conv:=
-"
-DEPEND="
- dev-ml/jbuilder
- test? (
- dev-ml/ounit
- ppx? ( dev-ml/ppx_driver dev-ml/ppx_sexp_conv )
- )
- ${RDEPEND}
-"
-
-get_targets() {
- local tgt="cstruct,cstruct-unix"
- use lwt && tgt+=",cstruct-lwt"
- use async && tgt+=",cstruct-async"
- use ppx && tgt+=",ppx_cstruct"
- echo "${tgt}"
-}
-
-src_compile() {
- jbuilder build -p $(get_targets) || die
-}
-
-src_test() {
- jbuilder runtest -p $(get_targets) || die
-}
-
-src_install() {
- opam-install cstruct
- opam-install cstruct-unix
- use lwt && opam-install cstruct-lwt
- use async && opam-install cstruct-async
- use ppx && opam-install ppx_cstruct
-}