summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-10-06 15:01:39 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-10-06 15:11:14 +0200
commitffda4fe925955ab47bb880aa750189566ccba6f3 (patch)
tree6c04c3e038d3e15d58e4d655276edade02dc88c4 /dev-ml
parentdev-ml/ocaml-ctypes: Remove old (diff)
downloadgentoo-ffda4fe925955ab47bb880aa750189566ccba6f3.tar.gz
gentoo-ffda4fe925955ab47bb880aa750189566ccba6f3.tar.bz2
gentoo-ffda4fe925955ab47bb880aa750189566ccba6f3.zip
dev-ml/ocaml-ctypes: bump to 0.13.0
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-ctypes/Manifest1
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.13.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ctypes/Manifest b/dev-ml/ocaml-ctypes/Manifest
index 66fe6a4e49f1..843d2168cd52 100644
--- a/dev-ml/ocaml-ctypes/Manifest
+++ b/dev-ml/ocaml-ctypes/Manifest
@@ -1,3 +1,4 @@
DIST ocaml-ctypes-0.11.2.tar.gz 203564 SHA256 708e2c5501ba00b3ed6726a7da1c2b58f607859e8e1cc0381eefd222510488d6 SHA512 f3d75e9e596f68438733090fea8c675624c3b186a77c3adf1eca8f12cc2da336f0f5b1688c2ee788726e873bbb0c4dce1d237d53d1637d78e4ad6a8eae1f912a WHIRLPOOL cbf74628695e01dfe2e379a7c645313e36eaae98f733cda231a290960e52241c96bcc2fb8491daa28b964cf06c0d43a41282767a2d9fa1a4a6f395736eb08864
DIST ocaml-ctypes-0.11.3.tar.gz 204959 SHA256 683b0215dca7bba797404869a80564cd4901a0a3f3c14bd65be7656c40b2329d SHA512 e7698954a6b683869a1482af8fe1bbeb5ccf693c2bb8583e2c19c5da92ed2730466e373c6f53d9ff9f09c2bdedf102da3f76b75511d7f9b7d266ac0765999f94 WHIRLPOOL ddeb6cf4b2b4c611bfe26f94974eaaa69415164825c5744d59b5afe388230cedad4d4c12b7d3753da31899af01f10c642f3478f9cc4270d49e70057023f61450
DIST ocaml-ctypes-0.12.1.tar.gz 199686 SHA256 127298c14af89625ebd300c08420e8629df98ebcff016fe6c1d0d106a0542810 SHA512 801c66395d843c9e410736a06ab5e03bbe22851a364dc9b9444f49dc133e0f5e0b7a1c31e88de56d23a21817cb35595a1b6743c430c8c1a689b7ae12adc8856f WHIRLPOOL 6179ea58bd7f5f03ff04806fd49c21637ad903cbfb0b16c3a255e6a9f2b9d32f2f97e15f86cec2692f84464121f496fc674d0f1e10ba80796e232d59c49a0a33
+DIST ocaml-ctypes-0.13.0.tar.gz 200959 SHA256 81f61e13b789b57b8055d4a22f0e41ae1309e0b9da86b0472bdb7bed0537f4f7 SHA512 ba2e4cd77d42cf032d823e26f94a8cc37d81ac12bafd40c5d61685d66c97e18996a286dd8d486c94ad4a34e4214e55104e6283158962871e7f0722b2144f7a7d WHIRLPOOL 6c3e1a039b3f0f77149ff00c6bc7e3cdcc8c07c8f9bc17435687f68d9bd4f830b53d786b240117d6b8d10f53bfa69229481590dda22aaff7647282e510bb31c3
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.13.0.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.13.0.ebuild
new file mode 100644
index 000000000000..1fbd65d357d0
--- /dev/null
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.13.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Library for binding to C libraries using pure OCaml"
+HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
+SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02:=[ocamlopt]
+ virtual/libffi
+ dev-ml/integers:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit dev-ml/lwt )"
+
+src_compile() {
+ emake -j1
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ findlib_src_install
+ dodoc CHANGES.md README.md
+}