summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-03-21 13:44:38 +1300
committerKent Fredric <kentnl@gentoo.org>2018-03-21 13:58:24 +1300
commited08a23a6851fc365b1a538789258f4649091849 (patch)
tree2c37c580ba16baa95d5d01bf2a169995a0848c8d /dev-perl/Alien-wxWidgets
parentsys-fs/owfs: Drop versionator eclass usage (diff)
downloadgentoo-ed08a23a6851fc365b1a538789258f4649091849.tar.gz
gentoo-ed08a23a6851fc365b1a538789258f4649091849.tar.bz2
gentoo-ed08a23a6851fc365b1a538789258f4649091849.zip
dev-perl/Alien-wxWidgets: Fix use of wxwidgets eclass
EAPI5 auto-setup the wxwidgets magic, but EAPI6 requires explicit invocation to function. This omission means Alien-wxWidgets would get built with whatever was currently selected with "eselect wxwidgets", ultimately resulting in compilation failure in dev-perl/Wx when the wx implementation was either wxGTK 2.8, or the GTK3 version of wxGTK3 Bug: https://bugs.gentoo.org/623042 Bug: https://bugs.gentoo.org/627180 Bug: https://bugs.gentoo.org/615246 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Alien-wxWidgets')
-rw-r--r--dev-perl/Alien-wxWidgets/Alien-wxWidgets-0.690.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Alien-wxWidgets/Alien-wxWidgets-0.690.0-r1.ebuild b/dev-perl/Alien-wxWidgets/Alien-wxWidgets-0.690.0-r1.ebuild
new file mode 100644
index 000000000000..4a697f0903d3
--- /dev/null
+++ b/dev-perl/Alien-wxWidgets/Alien-wxWidgets-0.690.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WX_GTK_VER=3.0
+DIST_AUTHOR=MDOOTSON
+DIST_VERSION=0.69
+inherit wxwidgets perl-module
+
+DESCRIPTION="Building, finding and using wxWidgets binaries"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="gstreamer opengl test"
+
+RDEPEND="
+ >=x11-libs/wxGTK-3:3.0[gstreamer=,opengl=,tiff,X]
+ >=dev-perl/Module-Pluggable-2.600.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-CBuilder-0.24
+ >=virtual/perl-File-Spec-1.500.0
+ >=dev-perl/Module-Build-0.280.0
+ test? ( virtual/perl-Test-Simple )
+"
+
+src_configure() {
+ setup-wxwidgets
+ myconf=( --wxWidgets-build=0 )
+ perl-module_src_configure
+}
+
+src_test() {
+ perl_rm_files t/zz_pod.t t/zy_pod_coverage.t
+ perl-module_src_test
+}