summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-05-08 23:11:46 +1200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-05-21 02:11:08 +0200
commitcfccd023a6210c915399ffae3d74c8d4d2384b5e (patch)
tree4087f481b9c3cf5c54f4c92814f0601511d0a06a /dev-perl/AnyEvent-CacheDNS/AnyEvent-CacheDNS-0.80.0.ebuild
parentdev-perl/App-Nopaste: Add missing dependencies (diff)
downloadgentoo-cfccd023a6210c915399ffae3d74c8d4d2384b5e.tar.gz
gentoo-cfccd023a6210c915399ffae3d74c8d4d2384b5e.tar.bz2
gentoo-cfccd023a6210c915399ffae3d74c8d4d2384b5e.zip
dev-perl/AnyEvent-CacheDNS: Disable tests without explict network grants.
Testing does DNS lookups, which fail under network-sandboxing. Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
Diffstat (limited to 'dev-perl/AnyEvent-CacheDNS/AnyEvent-CacheDNS-0.80.0.ebuild')
-rw-r--r--dev-perl/AnyEvent-CacheDNS/AnyEvent-CacheDNS-0.80.0.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-perl/AnyEvent-CacheDNS/AnyEvent-CacheDNS-0.80.0.ebuild b/dev-perl/AnyEvent-CacheDNS/AnyEvent-CacheDNS-0.80.0.ebuild
index e97462d66d54..8fb37bc3dccf 100644
--- a/dev-perl/AnyEvent-CacheDNS/AnyEvent-CacheDNS-0.80.0.ebuild
+++ b/dev-perl/AnyEvent-CacheDNS/AnyEvent-CacheDNS-0.80.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -22,3 +22,11 @@ DEPEND="${RDEPEND}
>=dev-perl/Module-Build-0.400.0
test? ( virtual/perl-Test-Simple )
"
+src_test() {
+ local my_test_control=${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}
+ if has network ${my_test_control}; then
+ perl-module_src_test
+ else
+ einfo "Tests skipped without DIST_TEST_OVERRIDE =~ network: Fails under network sandboxing"
+ fi
+}