summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-04-27 23:56:36 +1200
committerKent Fredric <kentnl@gentoo.org>2020-04-28 00:14:53 +1200
commit467e583a610460af8f60708eeca892aa98a3a0f3 (patch)
tree8cc9314cf8d32860e2ee51b798cafa5dbea177a2 /dev-perl/Apache-LogFormat-Compiler/Apache-LogFormat-Compiler-0.360.0.ebuild
parentdev-python/python-distutils-extra: Bump to 2.44 (diff)
downloadgentoo-467e583a610460af8f60708eeca892aa98a3a0f3.tar.gz
gentoo-467e583a610460af8f60708eeca892aa98a3a0f3.tar.bz2
gentoo-467e583a610460af8f60708eeca892aa98a3a0f3.zip
dev-perl/Apache-LogFormat-Compiler: Bump to version 0.360.0
- EAPI7 Upstream: - Repackaging changes only Package-Manager: Portage-2.3.97, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Apache-LogFormat-Compiler/Apache-LogFormat-Compiler-0.360.0.ebuild')
-rw-r--r--dev-perl/Apache-LogFormat-Compiler/Apache-LogFormat-Compiler-0.360.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/Apache-LogFormat-Compiler/Apache-LogFormat-Compiler-0.360.0.ebuild b/dev-perl/Apache-LogFormat-Compiler/Apache-LogFormat-Compiler-0.360.0.ebuild
new file mode 100644
index 000000000000..4369d34dc64f
--- /dev/null
+++ b/dev-perl/Apache-LogFormat-Compiler/Apache-LogFormat-Compiler-0.360.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=KAZEBURO
+DIST_VERSION=0.36
+DIST_EXAMPLES=("eg/*")
+inherit perl-module
+
+DESCRIPTION="Compile an Apache log format string to perl-code"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# POSIX -> perl
+RDEPEND="
+ >=dev-perl/POSIX-strftime-Compiler-0.300.0
+ virtual/perl-Time-Local
+ >=dev-lang/perl-5.8.4
+"
+DEPEND="
+ dev-perl/Module-Build-Tiny
+"
+# HTTP::Request::Common -> HTTP-Message
+# Test::More -> perl-Test-Simple
+# URI::Escape -> URI
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-Tiny-0.35.0
+ test? (
+ dev-perl/HTTP-Message
+ dev-perl/Test-MockTime
+ >=virtual/perl-Test-Simple-0.980.0
+ dev-perl/Test-Requires
+ >=dev-perl/Try-Tiny-0.120.0
+ >=dev-perl/URI-1.600.0
+ )
+"