summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-09-20 03:45:27 +1200
committerKent Fredric <kentnl@gentoo.org>2020-09-20 03:49:33 +1200
commit5a502711017be0b99f91ad85845a876da6670788 (patch)
tree0382f404d1a838906d0e41a244f6f6f6332b5f57 /dev-perl/Apache-Session/Apache-Session-1.940.0.ebuild
parentapp-admin/restart-services: remove old version (diff)
downloadgentoo-5a502711017be0b99f91ad85845a876da6670788.tar.gz
gentoo-5a502711017be0b99f91ad85845a876da6670788.tar.bz2
gentoo-5a502711017be0b99f91ad85845a876da6670788.zip
dev-perl/Apache-Session: Bump to version 1.940.0
- Strip unwanted tests Upstream: - Throw explict error when Apache::Session::Lock::MySQL lacks a LockDataSource Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Apache-Session/Apache-Session-1.940.0.ebuild')
-rw-r--r--dev-perl/Apache-Session/Apache-Session-1.940.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/Apache-Session/Apache-Session-1.940.0.ebuild b/dev-perl/Apache-Session/Apache-Session-1.940.0.ebuild
new file mode 100644
index 000000000000..a2c8eb15a557
--- /dev/null
+++ b/dev-perl/Apache-Session/Apache-Session-1.940.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=CHORNY
+DIST_VERSION=1.94
+inherit perl-module
+
+DESCRIPTION="A persistence framework for session data"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Digest-MD5
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ virtual/perl-Storable
+"
+DEPEND="
+ dev-perl/Module-Build
+"
+BDEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ >=dev-perl/Test-Deep-0.82.0
+ >=dev-perl/Test-Exception-0.150.0
+ >=virtual/perl-Test-Simple-0.470.0
+ )
+"
+PERL_RM_FILES=(
+ # Harmful at best
+ t/pod.t
+ # maintainer only
+ t/99postgres.t
+ t/99oracle.t
+)