summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-04-30 11:05:15 +1200
committerKent Fredric <kentnl@gentoo.org>2020-04-30 11:14:40 +1200
commitcaac7edcf31b3f115246f9123f4fc4c4dc1e0b46 (patch)
tree28b4f6a07819c9d95c54c685ffceae93dc610ccf /dev-perl/Authen-NTLM/Authen-NTLM-1.90.0-r2.ebuild
parentdev-python/moto-1.3.14: Version bump, add py38 (diff)
downloadgentoo-caac7edcf31b3f115246f9123f4fc4c4dc1e0b46.tar.gz
gentoo-caac7edcf31b3f115246f9123f4fc4c4dc1e0b46.tar.bz2
gentoo-caac7edcf31b3f115246f9123f4fc4c4dc1e0b46.zip
dev-perl/Authen-NTLM: -r bump for EAPI7
- EAPI7 - Parallel Tests - Remove redundant OPTIMIZE (no XS here) Package-Manager: Portage-2.3.97, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Authen-NTLM/Authen-NTLM-1.90.0-r2.ebuild')
-rw-r--r--dev-perl/Authen-NTLM/Authen-NTLM-1.90.0-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/Authen-NTLM/Authen-NTLM-1.90.0-r2.ebuild b/dev-perl/Authen-NTLM/Authen-NTLM-1.90.0-r2.ebuild
new file mode 100644
index 000000000000..01a26e961259
--- /dev/null
+++ b/dev-perl/Authen-NTLM/Authen-NTLM-1.90.0-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_NAME=NTLM
+DIST_AUTHOR=NBEBOUT
+DIST_VERSION=1.09
+inherit perl-module
+
+DESCRIPTION="An NTLM authentication module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=virtual/perl-MIME-Base64-3.00
+ dev-perl/Digest-HMAC"
+BDEPEND="${RDEPEND}
+ test? ( virtual/perl-Test-Simple )
+"
+PERL_RM_FILES=(
+ "t/99_pod.t"
+)