summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-04 01:34:01 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-04 02:59:46 +1200
commitf7aeb03ee35c4f4f3a804ed77821a04a00793b54 (patch)
treef418f58cf81155570dfce3153420d11d46396fd2 /dev-perl/B-Hooks-Parser/B-Hooks-Parser-0.210.0-r1.ebuild
parentdev-perl/B-Hooks-OP-Check: -r bump for EAPI7 + CFLAGS love (diff)
downloadgentoo-f7aeb03ee35c4f4f3a804ed77821a04a00793b54.tar.gz
gentoo-f7aeb03ee35c4f4f3a804ed77821a04a00793b54.tar.bz2
gentoo-f7aeb03ee35c4f4f3a804ed77821a04a00793b54.zip
dev-perl/B-Hooks-Parser: -r bump for CFLAGS love
- Ensure CFLAGS passed to make/compiler Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/B-Hooks-Parser/B-Hooks-Parser-0.210.0-r1.ebuild')
-rw-r--r--dev-perl/B-Hooks-Parser/B-Hooks-Parser-0.210.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/B-Hooks-Parser/B-Hooks-Parser-0.210.0-r1.ebuild b/dev-perl/B-Hooks-Parser/B-Hooks-Parser-0.210.0-r1.ebuild
new file mode 100644
index 000000000000..2d76e80a60d7
--- /dev/null
+++ b/dev-perl/B-Hooks-Parser/B-Hooks-Parser-0.210.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.21
+inherit perl-module
+
+DESCRIPTION="Interface to perls parser variables"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-perl/B-Hooks-OP-Check-0.180.0
+ virtual/perl-XSLoader
+ virtual/perl-parent
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/ExtUtils-Depends-0.302.0
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/B-Hooks-EndOfScope
+ virtual/perl-File-Spec
+ dev-perl/Test-Fatal
+ virtual/perl-Test-Simple
+ )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}