summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-04-08 08:38:23 +1200
committerKent Fredric <kentnl@gentoo.org>2017-04-08 08:38:23 +1200
commitbbcb87a14f44e01b4a86c7ab8ea95b1b2f984cf8 (patch)
tree70312cd8ee27d0a6973c9af4c9f23e27cd1ef072 /dev-perl/B-OPCheck/B-OPCheck-0.320.0.ebuild
parentdev-perl/Bio-ASN1-EntrezGene: Bump to 1.720.0 (diff)
downloadgentoo-bbcb87a14f44e01b4a86c7ab8ea95b1b2f984cf8.tar.gz
gentoo-bbcb87a14f44e01b4a86c7ab8ea95b1b2f984cf8.tar.bz2
gentoo-bbcb87a14f44e01b4a86c7ab8ea95b1b2f984cf8.zip
dev-perl/B-OPCheck: Bump to version 0.320.0
- EAPI6 - Parallel Testing Upstream: - Fix compilation on perl 5.26 w/ op_sibling removal - Remove redundant Perl_check_t definition Bug: https://bugs.gentoo.org/614944 Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-perl/B-OPCheck/B-OPCheck-0.320.0.ebuild')
-rw-r--r--dev-perl/B-OPCheck/B-OPCheck-0.320.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/B-OPCheck/B-OPCheck-0.320.0.ebuild b/dev-perl/B-OPCheck/B-OPCheck-0.320.0.ebuild
new file mode 100644
index 000000000000..bae935ee96f3
--- /dev/null
+++ b/dev-perl/B-OPCheck/B-OPCheck-0.320.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.32
+inherit perl-module
+
+DESCRIPTION="PL_check hacks using Perl callbacks"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/B-Utils-0.80.0
+ virtual/perl-Carp
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Scope-Guard
+ virtual/perl-XSLoader
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/ExtUtils-Depends-0.302.0
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-Module-Metadata
+ virtual/perl-Test-Simple
+ )
+"