summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-02-23 12:45:58 +1300
committerKent Fredric <kentnl@gentoo.org>2017-02-23 14:46:57 +1300
commit505eb9d8c5fa0f2643ccd34ba87112bcb32b111b (patch)
treebd39a484648261d9095b0d1a2b43a0dc53bbee81 /dev-perl/BZ-Client/BZ-Client-4.400.100.ebuild
parentdev-util/doxy-coverage: initial commit (diff)
downloadgentoo-505eb9d8c5fa0f2643ccd34ba87112bcb32b111b.tar.gz
gentoo-505eb9d8c5fa0f2643ccd34ba87112bcb32b111b.tar.bz2
gentoo-505eb9d8c5fa0f2643ccd34ba87112bcb32b111b.zip
dev-perl/BZ-Client: Bump to version 4.4001
- Add USE=examples - Streamline test handling Upstream: - Comment->get() can now query by #bugid - Tests fenced off without AUTHOR/NETWORK testing environments - Misc doc fixes Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-perl/BZ-Client/BZ-Client-4.400.100.ebuild')
-rw-r--r--dev-perl/BZ-Client/BZ-Client-4.400.100.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-perl/BZ-Client/BZ-Client-4.400.100.ebuild b/dev-perl/BZ-Client/BZ-Client-4.400.100.ebuild
new file mode 100644
index 000000000000..599b3d33ab0b
--- /dev/null
+++ b/dev-perl/BZ-Client/BZ-Client-4.400.100.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=DJZORT
+DIST_VERSION=4.4001
+DIST_EXAMPLES=("eg/*")
+inherit perl-module
+
+DESCRIPTION="A client for the Bugzilla web services API."
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/DateTime-Format-ISO8601
+ dev-perl/DateTime-Format-Strptime
+ dev-perl/DateTime-TimeZone
+ virtual/perl-Encode
+ virtual/perl-File-Spec
+ dev-perl/HTTP-CookieJar
+ virtual/perl-HTTP-Tiny
+ dev-perl/URI
+ dev-perl/XML-Parser
+ dev-perl/XML-Writer
+ virtual/perl-parent
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.280.0
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Clone
+ virtual/perl-Data-Dumper
+ dev-perl/DateTime
+ dev-perl/IO-Socket-SSL
+ dev-perl/Test-RequiresInternet
+ virtual/perl-Test-Simple
+ dev-perl/Text-Password-Pronounceable
+ )
+"
+
+src_test() {
+ has network ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}} && export TEST_AUTHOR=1
+ perl_rm_files t/author-* t/release-*
+ perl-module_src_test
+}