summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Benchmark-Timer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Benchmark-Timer')
-rw-r--r--dev-perl/Benchmark-Timer/Benchmark-Timer-0.710.600.ebuild28
-rw-r--r--dev-perl/Benchmark-Timer/Benchmark-Timer-0.710.700.ebuild28
-rw-r--r--dev-perl/Benchmark-Timer/Manifest2
-rw-r--r--dev-perl/Benchmark-Timer/metadata.xml9
4 files changed, 67 insertions, 0 deletions
diff --git a/dev-perl/Benchmark-Timer/Benchmark-Timer-0.710.600.ebuild b/dev-perl/Benchmark-Timer/Benchmark-Timer-0.710.600.ebuild
new file mode 100644
index 000000000000..bdc5ea8d67f4
--- /dev/null
+++ b/dev-perl/Benchmark-Timer/Benchmark-Timer-0.710.600.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DCOPPIT
+MODULE_VERSION=0.7106
+inherit perl-module
+
+DESCRIPTION="Perl code benchmarking tool"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Statistics-TTest
+ virtual/perl-Time-HiRes
+"
+
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.360.0
+ test? ( virtual/perl-Test-Simple )
+"
+
+SRC_TEST=do
diff --git a/dev-perl/Benchmark-Timer/Benchmark-Timer-0.710.700.ebuild b/dev-perl/Benchmark-Timer/Benchmark-Timer-0.710.700.ebuild
new file mode 100644
index 000000000000..219afe785e0e
--- /dev/null
+++ b/dev-perl/Benchmark-Timer/Benchmark-Timer-0.710.700.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DCOPPIT
+MODULE_VERSION=0.7107
+inherit perl-module
+
+DESCRIPTION="Perl code benchmarking tool"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Statistics-TTest
+ virtual/perl-Time-HiRes
+"
+
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.360.0
+ test? ( virtual/perl-Test-Simple )
+"
+
+SRC_TEST=do
diff --git a/dev-perl/Benchmark-Timer/Manifest b/dev-perl/Benchmark-Timer/Manifest
new file mode 100644
index 000000000000..fb61fbcd3d92
--- /dev/null
+++ b/dev-perl/Benchmark-Timer/Manifest
@@ -0,0 +1,2 @@
+DIST Benchmark-Timer-0.7106.tar.gz 45648 SHA256 f4a2d6103197418b488ff85ca2272dc6a7f4b5f642921d7cebab48311d871cea SHA512 89fbf2695886a08efdbedd5cf85fe65dcf61ef422a747fe947950404cc0a7e7bdb7362b69253ee787166803eb56842966362d29ecb6e7001c32cebbaf28e5ee8 WHIRLPOOL c49ecf13566f2ebade1c8521d43db44dc9e69d19f78c1a1cb9be0f4ca05a6c40a20433200c80dd2ede41f7c5766b5a03ac2cdc3ba99c7ec5103285e1108b127d
+DIST Benchmark-Timer-0.7107.tar.gz 45734 SHA256 64f70fabc896236520bfbf43c2683fdcb0f2c637d77333aed0fd926b92226b60 SHA512 6faa50a90173a075a4bb398212e2db77348f59a47ff483db9e1885dc7dce9636557684574a21f228c53f0c29a468e663706843840b2e59abbaaed1222f400e05 WHIRLPOOL 8f09e9687a42f82b4bccd47aca76ab10d8d406c27be4fb5224e188a55c24235067702e4e19a97677982771b46aa101abf5fe64779148f97c4afca34cb8f0552f
diff --git a/dev-perl/Benchmark-Timer/metadata.xml b/dev-perl/Benchmark-Timer/metadata.xml
new file mode 100644
index 000000000000..ec3cbfb1a133
--- /dev/null
+++ b/dev-perl/Benchmark-Timer/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Benchmark-Timer</remote-id>
+ <remote-id type="cpan-module">Benchmark::Timer</remote-id>
+ </upstream>
+</pkgmetadata>